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Installation setup, software updates, reference libraries and documentation are also available from the
Restricted Area of the website www.eliwell.it once you have registered.
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Eliwell Controls Srl

Via dell'Industria, 15 Z. |. Paludi
32010 Pieve d'Alpago (BL) - Italy
Telephone +39 (0) 437 986 111
Facsimile +39 (0) 437 989 066

Sales:

+39(0) 437 986 100 (ltaly)

+39(0) 437 986 200 (other countries)
saleseliwell@invensys.com

Technical helpline: +39 (0) 437 986 250
eliwell.freeway@invensys.com
www.eliwell.it

DISCLAIMER

Eliwell Controls srl declines all responsibility for injury or damage deriving from the installation
or use of this software other than for the purpose and in the manner described in this manual.
Every care has been taken in preparing this document; however, Eliwell Controls srl cannot accept
liability for any damage resulting from its use.

Within the limits established by law, Eliwell Controls srl shall under no circumstances be held
responsible for specific, accidental, direct or indirect damage (including but not restricted to
damage resulting from loss or absence of earnings, interruption of activity, loss of data or any
other economic loss) deriving from use of or failure to use this software product or from the supply
of or failure to supply the associated technical support service, even in cases in which Eliwell
Controls srl has been previously notified of the risk of such damage.
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INTRODUCTION [|| [free

GENERAL DESCRIPTION

FREE Studio is a quick, effective development tool for creating and

customising new programs for all types of IEC application, which is particularly Stu d io
suited to HVAC/R requirements.

The use of several different programming languages in accordance with
IEC61131-3 regulations (programming standard for industrial control), makes
it possible to develop new algorithms or entire programs totally unassisted,

N

which can then be uploaded to IEC 61 1 31 '3

guaranteeing the utmost confidentiality with appropriate security.

FREE Smart via PC or Multi Function key
FREE Evolution via PC or USB development

environment

COMPONENTS N )

All basic components, interfaces, converters and accessories are described
below!l.

FREE Studio software

The FREE Studio!? software suite and its functions will be illustrated in this document.
The FREE Studio software suite consists of 5 development environments for programming the FREE Smart, FREE Panel &
FREE Evolution programmable controllers:

FREE Studio Application, dedicated to developers, for creating and managing libraries, IEC applications and diagnostics.
FREE Studio Device, dedicated to users, for managing previously developed IEC applications, downloading them to the

target!®! device and modifying device parameters from a serial port.

FREE Studio Simulation, dedicated to software developers, for executing PLC applications and HMI pages (Evolution
only) in a simulation environment without the need to have a target!®

The following 2 development environments are only available for FREE Evolution:

FREE Studio Connection'®], dedicated to software developers, for creating networks
FREE Studio User Interface, dedicated to software developers, for personalising the graphical interface on built-in

terminals and other terminals.

DM Interface (DMI)
Component required for FREE Smart only:

Component required for connection to PC

The USB/TTL-12C hardware interface to be used in association with the software suite enables you to:

use the software itself.
connect to the target device in order to control it.
connect to the Multi Function Key (MFK) component.

Multi Function key (MFK)
Component required for FREE Smart only:

This is a memory support, which allows you to:

1

2.
3.
4.

update the firmware of the target device.

update the IEC application of the target device.
update the parameter values of the target device.
download the parameter values from the target device.

Connection cables
Components required for FREE Smart only:

“Yellow” cable with JST - molex terminals, see Connection Modes chapter for use instructions
“Blue” cable with JST - JST terminals, see Connection Modes chapter for use instructions
USB-A/A extension lead, 2 m

Converters
Components required for FREE Evolution only:

USB/485 adapter
USB/CAN adapter

Note: alternatively if there is a R§232 serial port, Evolution can be connected to the PC using an RS485/RS232 adapter

ABhWN=

the interfaces and converters are dedicated to Smart, Panel or Evolution.

Software suite or package. See abbreviations and definitions

programmable controller. See abbreviations and definitions

An IEC application can be downloaded directly onto the Simulator without the need to have a physical Smart or Evolution
For Evolution only: Connection is the entry point of the software suite - see Target chapter

FREE Studio - Quick Start page 1



Plug-in (Evolution)

A wide range of plug-in, 2DIN rail-mounted modules allows integration with industrial systems, BMS and Ethernet networks.
Note: not available for FREE Panel, which has 3 on-board RS485, CAN and ETHERNET serials.

Abbreviations and definitions

e Application, Device, Connection, Simulation, UserInterface: abbreviations of FREE (Studio) Application, FREE
Device, FREE Connection, FREE Simulation and FREE UserInterface respectively. Software suite

e |EC application, PLC Application, PLC: an application made to IEC61131-3 (industrial control programming
standards) by means of the Application development environment (tool) to be downloaded to the target using
Application or Device

e Target device, Target: name given to the FREE Smart, FREE Evolution or FREE Evolution Panel (EVP)

programmable controller, or “instrument”

DMI: abbreviation of DM Interface

HMI: acronym of Human Machine Interface. Graphical interface developed with Userinterface

Instance: object of a predefined object class (function block, template, etc)

IEC language: programming language to IEC61131-3

BIOS menu, BIOS: factory-set BIOS parameters menu. Not modifiablel®

MFK: abbreviation of Multi Function Key

Quick Start: this document

Smart: abbreviation of FREE Smart; Evolution: abbreviation of FREE Evolution; EVP: abbreviation of FREE Panel

Studio: abbreviation of FREE Studio. The software suite described in this document

Tab. The workspace is divided into sections or panels. Each panel may in turn be subdivided into tabs (e.g. Resources

tab)

e Template: in this document it denotes a page template created with Userlnterface

e Panel or section: see Tab (e.g. Project panel)

Note: Many definitions and abbreviations are standard information technology and/or PLC terms and are not listed here.

For example a Function is a standard term. Other terms, such as Function Block, will be described in the relevant

paragraphs.

IMPORTANT:

This Quick Start:

e isaimed at designers and developers and requires a knowledge of one or more IEC61131-3 standard programming
languages.

e isdesigned to provide a first-level overview of the installation, functions and use of FREE Studio

* requires a reading of FREE Smart installation manual 9MAxX00036 and/or FREE Panel manual 9MAx00046 and/or
FREE Evolution manual 9MAx00042 (x = 0: IT; 1: EN; 2: FR; 3: ES; 5: DE) available in electronic format only (PDF) from
www.eliwell.it subject to registration with the restricted area

e isavailable in electronic format only (PDF) from www.eliwell.it subject to registration with the restricted area

SYSTEM RESOURCES

The developer has the following resources available on the target devices for IEC programming

Smart Evolution/Panel

CPU

Available memory for
Application
Available memory for
User Interface
FLASH memory data
RAM Memory*

RAM Memory**
EEPROM variables

* automatic mapping
** Modbus mapping

6 The BIOS cannot be modified but can be updated.

FREE Studio - Quick Start page 2



OPERATING SYSTEMS

Windows XP Home SP2 or SP3 lItalian, English, Spanish and German.
Windows XP Professional SP2 or SP3 Italian, English, Spanish and German.
Windows 7 Home Premium ltalian, English, Spanish and German.
Windows 7 Professional Italian, English, Spanish and German.

Windows 7 Ultimate Italian, English, Spanish and German!'l.

OTHER SOFTWARE
(FREE Smart only)
Driver AT90USBxxx CDC USB to UART MGM for use of the DM interfacel?

See DM Interface Installation

MINIMUM HARDWARE

1024x768 graphic resolution
700MHz CPU

1 GB RAM

HD with 5GB of disk space

1 USB portt3!

Mouse or other pointing device.
1 CD-RW drive

Note: A typical installation (available in English, standard libraries) requires about 500 Mbyte of disk space.
Allow a further 1GByte of disk space for installing libraries and dedicated applications.

To download the application, you need the following components:

FREE SMART HARDWARE AND ACCESSORIES

1 FREE Smart SMD5500/C/S or a device from the FREE Smart family
1 DMI 100-3 Manufacturer + yellow TTL cablel®

1 optional MFK + TTL blue cable

FREE Smart!®! power cables and transformer

FREE EVOLUTION HARDWARE AND ACCESSORIES

e 1 FREE Evolution EVD7500/U or request the demo case (Demo Case)
e 1USB/RS485 or USB/CANOpen or plug-in Ethernet converter
e  35VA transformer for power supply to FREE Evolution

INTERNET

The installation set-up is supplied on CD-RW.

The installation set-up, software updates, libraries and documentation are also available from www.eliwell.it subject to
registration with the Restricted Area (see Technical Support).

Make sure an Internet connection is available for access to software and manual documentation.

For all: other languages not explicitly tested

available in the installation package

For Evolution it is also possible to use a R$232 port by means of a R$232/RS485 converter.

For Smart (/S versions only) it is possible to use the RS232 port by means of R$232/RS485 converter with maximum speed 19200 baud.
TTL cannot be used in this case.

4 see Connection

5 FREE Smart does not need to be powered separately if it is connected to a PC by means of DMI. Use yellow TTL cable

WN =
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INSTALLING STUDIO

Run EliwellFREEStudio_xxx.exe!"! supplied by Eliwell and then follow the installation wizard as indicated in the following

screenshots.

1. Click "Next”

2. Click "l accept the agreement'?
3. Click "Next"”. When installation is complete, the FREE Studio icon will appear on the desktop.
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4. Click “Install”.
5. Installation in progress
6.  Click “Finish".
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APPLICATION ICONS
Click the FREE Studio icon on the desktop to access a folder containing the following links.
icon d ioti icon d ot
ription ription
(link) asariptio (link) eseriptio
Application Connection
L] development tool g development tool
for Smart & Evolution for Evolution
Device User Interface
= development tool development tool
for Smart & Evolution for Evolution
Simulation
development tool

-

for Smart & Evolution

Check the software version in advance with Eliwell Technical Support

2 To continue with installation, you must accept the License Agreement.
Carefully read the End User License Agreement (EULA) before continuing
The EULA is also available on the website http://www.eliwell.it/content.aspx?id=4533
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The Studio software suite is designed for use with Smart, Panel and Evolution target devices.

The selection of the most appropriate target for the needs of the developer is indicated in the chapter Defining Hardware
Requirements.

FREE WAY

The Studio software suite is unique for Smart and Evolution.
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Smart Panel Evolution

The entire system is named FREE Way: the FREE Studio software + FREE Smart, Panel & Evolution and Panel hardware.

FREE SMART

The Smart developer will only be able to use the Application and Device workspaces!™
The Smart developer will be able to launch Application to start programming.
The Smart user can use Device to download the IEC application previously compiled by the developer.

From Application it will always be possible to open Device directly without having to launch the program using the
FREE Studio icon.

FREE PANEL

The Panel developer will be able to use all workspaces!?!.
The Panel developer will be able to launch Connection to get started. Connection is the entry point for all development
activities, from PLC programming to creation of the HMI menu and downloading onto the target’® using Device.

From Connection it will always be possible to directly open User Interface, Application and Device without having to launch
the relative program using the FREE Studio icon.

FREE EVOLUTION

The Evolution developer will be able to use all workspaces.
The Evolution developer will be able to launch Connection to get started. Connection is the entry point for all development
activities, from PLC programming to creation of the HMI menu and downloading onto the target using Device.

From Connection it will always be possible to directly open User Interface, Application and Device without having to launch
the relative program using the FREE Studio icon.

including Simulation
not including Simulation
the target for Panel is EVP. The Evolution menus must be downloaded onto EVD and then “uploaded” from EVP as remote menus

WN =
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INSTALLING DM INTERFACE (DMI)™!

CONNECTING THE DM INTERFACE TO THE PC

Connect the DM interface to one of the USB ports on the PC.
You are advised to use the supplied USB extension lead for the connection.

DM INTERFACE SETUP

As soon as the DM interface is connected, the Windows XP®2l operating system installation wizard will start the installation
procedure. The steps to be followed are described below.

1. Onthe initial page, select the “No, not this time” option and click on “Next".
2. Setthe second option as indicated and click “Next".

The path you need to specify is the path of the program installation directory.
3. Click "Next"” and/or search for the indicated path with “Browse".
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4. The operating system will prompt for confirmation to install the drivers.
Click on “"Continue"?I,
5. When the operating system recognises the device (driver) as "AT90USBxxx CDC USB to UART MGMM, click on “Finish".
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This operation must be carried out after installing Studio. Installation required exclusively for Smart
The same installation procedure applies to all other operating systems.

ignore the warning message about compatibility with Windows XP

the file at90usbxxx_cdc.inf containing the driver is saved to C:\Program Files\Eliwell\FREE Studio
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Reading the DM interface COM port
Follow the steps below to check which COM port the operating system has assigned to the DM interface.

arOd =

data.

o

B Geationime npuler

Click the right mouse button on the "Resources” icon.

Select the "Computer Management" option in the contextual menu.
Click on "Peripherals Management'
Open the "Ports (COM & LPT)" options in the right window.
Read the port setting at the end of the "AT?0USBxxx CDC USB to UART MGM"” string or the string giving the DM interface

"in the left window.

In the example shown in the illustration, the setting is: COM 3.
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Changing the COM port setting

If there are contradictions, or for any other reason, another port can be assigned to the interface, as show in the illustration

below.

e 1. Right-click onthe COM portin question.

e 2. Click on “Properties”.

e 3. Selectthe Portsettings tab.

e 4. C(lick onthe Advanced button.

e 5. Changethe COM port number as desired.
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SMALL APPLICATIONS

FREE Smart was designed for small plants and in particular for

Manufacturers of:

e AT.U.s (Air Treatment Units)
e Chillers & Heat Pumps

* Rooftops

e Compressor Rooms

Installers/integrators of:

e  Airsystems

e Hydronic systems

e Combi systems (air/water)

FREE SMART SELECTION CRITERIA

The FREE Smart models are available in both a DIN rail-mounted version, which significantly reduces wiring times, or in the
regular Eliwell 32x74 format for panel mounting.

FREE Smart SMP has 2 models, giving you 6 digital inputs, up to 5 relay outputs, a TRIAC output, 2 PWM
analogue outputs, 3 configurable 0...10V/0...20mA/4...20mA analogue outputs and an Open Collector
digital output for an external relay.

The standard Eliwell 32x74mm format ensures versatility and ease of installation.

ol i
Ll L

FREE Smart SMD - SMC comes in a variety of models, giving you 6 digital inputs, up to 5 relay outputs, up to
2 TRIAC outputs, up to 2 PWM analogue outputs, up to 3 configurable 0...10V/0...20mA/4...20mA analogue
outputs and up to 2 Open Collector digital outputs for an external relay.

The 4DIN format guarantees maximum flexibility and easy installation.

I : l
-

It runs on 12-24V~ or 12-24V~/24V= power supplies.
For further details, see the FREE Smart installation manual.

FREE Smart SMD4500 - SMC4500/Espansione SME4500 have removable connectors both for the low
voltage inputs and the relay outputs.

Has different models, giving you up to 2 digital inputs, 4 relay outputs, up to 2 PWM Open Collector analogue
outputs, up to 2 0...10V/0 analogue outputs, one configurable 20mA/4...20mA output

or, as an alternative one 0...10V output on dedicated models.

B '
14 18|

The 4DIN format guarantees maximum flexibility and easy installation.

100-240V~ power supply
=5l
CONTINUITY WITH ENERGY FLEX

FREE Smart inherits from the Energy Flex series the characteristics of the /0 and the electrical
connections of the various models, to be combined with the corresponding expansions and keypads.
The two platforms also use the same accessories.

FREE Smart also inherits from the Flex series the interface with the standard Modbus RTU in
serial communication and the possibility of downloading parameter maps and applications via MFK.

1 Note that continuity with Energy Flex DOES NOT include the applications.
The applications (e.g. Air Treatment Units) are developed by Eliwell and available for download from the site.
Visit the site and/or contact Technical Support for further details

FREE Studio - Quick Start page 8



SELECTING AN INTERFACE

Smart 12-24V~/~/24V= is available in 3 versions: SMP for panel mounting and SMD/SMC for DIN rail mounting.

Al
[[Tiree
W

SMP 32x74 SMD 4DIN with display SMC 4DIN without display

I
]
L

é“
k4

1nl-*{8

The IEC application created by Application can be loaded on every version.
Menu navigation is identical for all models.

The SMP and SMD models have a 7-segment, 4-digit LED display.
The SMC model has no display so you need a remote terminal for configuration in the field.
For a description of the keys, user interface and connections, refer to installation manual 9MAx0036'2

Smart 100-240V~ is available in 3 versions: SMD/SMC4500 with DIN rail mounting and I/0O SME4500 expansion module with
DIN rail mounting:

frrrrrrrot - -

[|| free)

l.llllllllll ..... = = —— W : = e

SMD4500 4DIN with display SMC4500 4DIN without display SME4500 4DIN expansion
without display

The IEC application created by Application can be loaded on every version.

Menu navigation is identical for all models.

The SMD models have a 7-segment, 4-digit LED display.

The SMC model has no display so you need a remote terminal for configuration in the field.

For a description of the keys, user interface and connections, refer to installation manual 9MAx0036°

2-3 (x=0:1IT; 1: EN; 2: FR; 3: ES; 5: DE
X ) FREE Studio - Quick Start page 9



SELECTING OPTIONAL SMART MODULES

Some of the accessories used by Smart are listed below:

i

[
o

SKP 10 terminal 32x74 SKW22 terminal
with LCD display

without backlighting

gsk

=
.
SKP22 terminal SKP22L terminal
with LCD display with LCD display
without backlighting with backlighting

Smart

i 2l

SKW22L terminal
with LCD display
with backlighting

expansion modules (various models
available) SE600 4DIN without
display

e The SKP 10 remote terminal for panel mounting has the same interface as the main Smart module.
e The SKW22 remote terminal for wall-mounting has a dedicated interface with LCD display with or without backlighting.

For further details, see installation manual 8MAx021 83!

e The SKP22 remote terminal for panel mounting has a dedicated interface with LCD display with or without backlighting.

For further details, see installation manual 8MAx021 84!

e The SE600 expansion modules - available in various models - have 1/O similar to those of SMD

For details of connections and further modules and accessories, see installation manual 9MAx0036!5!

3-4-5 (x=0:IT; 1: EN; 2: FR; 3: ES; 5: DE)
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COMPLEX APPLICATIONS

FREE Evolution was designed for medium and large plants and in particular for

Manufacturers of:

e AT.U.s (Air Treatment Units)
e  Chillers & Heat Pumps

* Rooftops

e  Compressor Rooms

Installers/integrators of:

e  Airsystems

e Hydronic systems

e Combi systems (air/water)

FREE EVOLUTION SELECTION CRITERIA

EVD EVC

Evolution

FREE Evolution models are available in the 8 DIN rail-mounted version, with display (EVD model) or without display

(EVC model), both supplied with removable screw terminals for quick and easy installation.

FREE Evolution EVD/EVC comes in a variety of models based on which you can mount 9 digital inputs, up to 7 relay outputs, 5

configurable 0...10V/4...20mA analogue outputs

The /U models are also equipped as standard with one USB port and one mini USB port

The 8DIN format guarantees maximum flexibility and easy installation.

24V ~/= or 48V= power supply
For further details, see the FREE Evolution installation manual 9MAx0042!¢!

6 (x=0:IT; 1: EN; 2: FR; 3: ES; 5: DE)

FREE Studio - Quick Start page 11



SELECTING OPTIONAL MODULES AND EVOLUTION ACCESSORIES

Some of the accessories used by Evolution are listed below:

EVK1000 terminal wall mounting EVK1000

= =

&

FREE Evolution EVE expansion EVS plug-in

e FREE Evolution EVD comes with a built-in graphics user terminal whilst FREE Evolution EVC has no display and must be
connected to a remote EVK1000 graphics terminal for the configuration of BIOS parameters

e EVK1000 is available in the panel mounting version: a special backplate, available as an accessory, enables it to be wall
mounted

® Integration into industrial systems, BMS and Ethernet networks is permitted thanks to the plug-in EVS modules, available in
2DIN format, that connect quickly and intuitively to the main modules

The FREE Evolution EVE expansion module, without display, has the same format and the same 1/O as the main module.

FREE PANEL SELECTION CRITERIA Panel

o ] = o ] =

EVP3300/C EVP3500/C/RH wall mounting backplate

FREE Panel (EVP) modules are available in the panel mounting version: a special backplate, available as an accessory, enables

them to be wall mounted

There are two FREE Panel (EVP) models

1. FREE Evolution EVP 3300/C is equipped with CANopen, RS485 Modbus RTU and ETHERNET Modbus TCP serial, 3 inputs
(1 on-board NTC + 1 remote configurable NTC/DI +1 remote current/voltage configurable input)

2. FREE Evolution EVP 3500/C/R is equipped with CAN, RS485 and ETHERNET serial, 3 inputs (1 on-board humidity module
+ 1 on-board NTC + 1 remote configurable NTC/DI)

FREE Studio - Quick Start page 12



EVP comes with a built-in 128x64px graphical user terminal
24V ~/= or 48V= power supply

For further details, see the FREE Panel installation manual 9MAx0046!”!

CONNECTIVITY

The fundamental characteristic of Evolution is its wide connectivity

FREE Panel (EVP) can be used as a system controller, with gateway functions; used in combination with the FREE Evolution and

FREE Smart or third-party controllers it guarantees high performance in terms of memory, connectivity and user interface as well

as straightforward programming, maintenance and servicing.

FREE Panel models are all available with CANOpen RS-485 and ETHERNET as standard.

EVP can be used to:

* manage a local menu created with FREE Studio User Interface

* manage up to 10 remote menus, created with FREE Studio User Interface and uploaded from the respective FREE Evolution
devices connected to the network

e share network variables (binding)

EVD/EVC models are all available with CANOpen as standard.

Integrated RS485 or MPBUS serials are also available as standard, depending on the model.

Each EVC/EVC model can be connected to 12 EVE expansion modules via CANOpen or RS485 serial.

Integration into industrial systems, BMS and Ethernet networks is permitted thanks to the plug-in modules, available in 2DIN
format, that connect quickly and intuitively to the main modules.

Each Evolution can be connected to up to two terminals to view the integrated machine display. Using the RS485 network,
a Smart system acting as a slave can be connected in a network in which Evolution acts as master.

The EVK1000 terminal is available with CANOpen as standard. The EVK1000 terminal can read menus from EVD/EVC
Integrated RS485 or MPBUS are also available as standard, depending on the model.

4 )
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APPLICATIONS

Applications and object libraries for the FREE Way platform are available on the Eliwell website!"
The applications and object libraries will help to speed up your work even more, making FREE Studio even easier to use.

Smart applications

You can download, for example, different applications for UTA, that differ in terms of the complexity of the machines that they
can control, from simple units with single air channel and single battery to more complex units with dual channel, multiple

batteries and recuperator.

These applications, in addition to being
ready to use, conform to architecture
rules and can therefore be modified
easily to meet more specific or particular
needs.

(

-

~

The same section of the website also contains
documentation:

Architecture or Developer Manual
Developer Manual with architecture rules, aimed at
developers

User Manual
User Manual for individual
application

J

1 at the address (visible after registering and/or logging into the restricted area) pttp://www.eliwelLit/filedownload.as

FREE Studio - Quick Start page 14
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APPLICATION PANEL DEFINITIONS [|| [free

The Application work environment has various sections for developing the IEC application, e.g. programming in
IEC 61131-3 compatible language, testing, debugging and IEC application downloading to the target device.
N.B.: Application only downloads the IEC application.

Parameters (BIOS and PLC) and their default values are downloaded by Device and not by Application.

The sections (panels) are listed below:
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This section shows the work tools in the form of icons.
To display or hide the toolbars, simply right-click and

Tool select or deselect the desired tools.

A / bar
Some tools can be selected by means of key

combinations (shortcuts). See relevant chapter for details

The global and local variables of the code displayed in
B / Variables section D “Edit” (programs, function blocks and functions)
appear in this section
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Panel Name /

Section Section
Application

(o Project
D /
E Watch
F Oscilloscope
G Library
H Output

Panel

Project

Edit

Display variables with
application running

Display variables graph

Functions library

Messages

Description

The Project panel is divided into 3 tabs:

* Project - for managing the application code

e Definitions - for managing and defining complex
variables defined by the developer

e Resources - for managing the target device menu

This section enables you to write the program

This panel enables you to manage variables debugging
by displaying their status in numerical format when the
application is running and connected to the target device

Like the Watch panel, this panel enables you to manage
variables debugging by displaying their status in graph
format when the application is running and connected to
the target device

This tool enables you to manage default functions

libraries or functions libraries created by the developer.

The panel is divided into various tabs, one for each

library.

The tabs relating to the following are always available:

e  Operator and standard blocks: standard operators
(AND, OR, etc)

e Target variables: specific variables of the target
device

e Target blocks: specific functions of the target device

Any additional tabs are managed by means of the drop-

down menu Project > Library manager

This panel shows the messages relating to the
development of the project (file opening, compilation
errors, status of connection to target device, etc.)
Note: the connection to the target device is also visible
in the bottom right of the screen by means of coloured
messages (see Application Download)

The panels appear or remain hidden (see Shortcuts) and can be organised as the user wants in terms of size and layout.
Studio saves the last settings made

ICONS

The work tools are available via the drop-down menus or shortcuts

Panel A shows a series of icons that help the developer to create the application.
The toolbars are displayed via the menu View > Toolbars
Below are the most frequently used icons in the Main and Project toolbars

Main Toolbar

S ™ & BB b s

Project Toolbar

Li

WO LWa A
ORI S RIEE

C Casico Oc |ns Dl

F

The icons are self-explanatory. Apart from the first few icons, which are very similar to standard icons (Open project, Save

project, Copy, Paste etc.) there are icons with letters above them:
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Toolbar Function Function Shortcut
F Main Full screen Full Screen CTRL+U
W Main workspace WORKSPACE CTRL+W
o Main Sherliee OUTPUT CTRL+R
messages panel
L Main eies LIBRARY CTRL+L
library panel
Wa Main snenifels WATCH WINDOW CTRL+T
watch window
. show/hide ASYNCH GRAPHIC
A eIl asynch graphic window WINDOW CTRL+K
c PROJECT comple selosiod COMPILE F7
project only
Ca PROJECT complle allprejess COMPILE ALL -
Yes PROJECT Oppen imulkter SIMULATION MODE -
See Simulation chapter
CONNECTS TO THE
Co PROJECT connects to the target TARGET F5
Dc PROJECT Download code DOWNLOAD CODE -
Ins PROJECT Insert record (variable, constant, INSERT RECORD i
alarm etc.)
Del PROJECT Delete record DELETE RECORD -
Project panel
Detailed display of Panel C / Project!!
- u = = = -
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Project tab

Definitions tab

Resources tab

1 view for Smart
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GETTING STARTED [|| [free

Smart m

FIRST START-UP

1. Click on the Launch FREE Studio icon on your Desktop
2. Click on the FREE Studio Application icon.

T -
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Studio - Application
1EZ A1131-3 developmant emdnonment
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You can now:
e Create a new project "New Project ...”
e note that the program suggests selection of the Smart, Evolution or Panel target
e inthis case select FreeSmart
e the numbers at the side indicate the firmware version (screen)
e Open an existing project “Open project ...”
e Open recent projects "Open an existing project ...” by selecting from a list
Existing projects have the extension .ppjs
The IEC application is made up of one project and one or more programs written in IEC code.
1 The word “Smart” at the start of this chapter indicates that the Application tool is available for Smart. All tools (including Application) are

available for Evolution. For Evolution you are advised - for First Start-up and Creation of a new program - to always start from the Connection
tool (see relevant chapter)
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CREATING A NEW PROJECT 1l

¢ Click New Project ... or
e select File > New Project from the drop-down menu!?

The dialogue box shown below appears, in which you can create, name and save a new project:
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New Project

The new project appears as shown in the figure:
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e  For a description of the icons, see Shortcuts
e Adescription of the programming languages is available in the Online Help - see "Support”
® The panelsin the standard development environment are described in the next chapter

The pages that follow explain how to create, develop and test a new application, with simple examples of libraries, function
blocks and elementary programs.

The figure shows an example of a project for Smart. The same procedure applies for Evolution. Exceptions will be pointed out as appropriate.

2
However you are advised in this case to always start from the Connection tool and to follow the procedure described in the relevant chapter
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CREATING A NEW PROGRAM::

Project Panel/Programs Folder.
Right-click and select New Program.

Every project contains by default the program main.

SELECTING THE IEC LANGUAGE

The following dialogue box appears:

ST o
|-|“|. ~Fmo W s e
s

o

_bwest | [ ]

New program in ST language

Select the desired programming language and enter a name.

The FREE STUDIO platform is compatible with all 5 standard programming languages (IEC 61131-3).

ST

IL

f var2:=var2+1;

if (var2=200) then
var2: =0;
varl: =not val

counter: =
if

FBD

7

\&

\3

LD
—

Main Start

\3

( Id true

st blinker.run
Id true

st blinker.run
cal trigger

\

™\

>

Each project may consist of several programs.
The developer may use one or more languages in the same project. Each new program actually offers the choice of
5 programming languages, 2 text-based and 3 graphics-based:

ST, Structured Text text

language

FBD, Functional Block Diagram language

LD, Ladder language

IL, Instruction List language
SFC, Sequential Function Chart language

text
graphical
graphical
text
graphical

OPENING AN EXISTING PROGRAM

If the developer already has an existing IEC application, simply open a .ppjs project from the menu File > Open Project or
select it from the list.

3

Creating a new program
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[|] |free|
WRITING A PROGRAM Ap

In the Edit panel, write the program that you intend to develop.
The elements of the development tools are presented generically below.
The appendix give some examples of simple programs which you can use to create a basic, functioning project

PROJECT PANEL / PROJECT TAB

Creating local variables

Using the drop-down menu, select Variables > Insert (new record) or click on the respective icon

The variable appears in yellow in the central section, and you can define its characteristics by clicking on the respective boxes.
Where multiple choices exist, you can choose from a set of options by clicking on the three dots (...).

a dialogue window will open

e Name

Type, to choose from one of the preset options or variables defined by the user (see picture)

Address: the default setting is automatic

Array: defines whether the variable is array type (if so, define its dimension) or not

Init value: initial value

Description

In the navigation tree below the program folder, the local variables will appear, identified by an icon
Note: The local variables are NOT static
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Creating a function block/function

In the same way as we create a program, it is possible to create

e afunction

* afunction block

in the desired programming language.

Note: Creating functions is available in 4 programming languages. SFC language is not supported for functions.

A function or function block is a (sub)program with inputs and outputs:

e afunction requires n inputs and a single output (RESULT) with the same name as the function. The function's local memory
is initialised each time the function is called

e afunction block requires n inputs and m outputs. The local memory of each instance of the function block is kept between
one call and the next (static memory)

Each function or function block can be used within a program simply by dragging and dropping the icon into the Edit section of
the program.

The function is used within the program by passing the input variables.
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The function block is used within the program as an instance in the same way as the declaration of a variable.

example in ST language of call to function and function block.
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Creating global variables

The navigation tree contains the folder Global Variables
From here you can create new
Global variables

Mapped variables
Constants

Retain variables!*!

Shared global resources
The shared global resources will appear in this section but will be defined in the Resources panel.

4

not currently supported on Smart and Evolution targets.
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ASSOCIATING A PROGRAM TO A TASK m

For a program to run, it must be associated to a task.

There are various types of task:

e BOOT Task runs once only at system start-up

e Init. Task runs each time the application is downloaded

e Timed. Task runs at regular intervals which can be set by the developer. The default setting is every 100ms

e Background. Task runs with low priority after the Timed tasks (between the end of one Timed task and the start of the
next).
Note Each new project has the main program associated to the background task (the main program can still be eliminated
and/or associated to other tasks).

To activate a task, go to the task you want, right-click and select Add program

PROJECT PANEL/RESOURCES TAB

The Resources tab enables you to define the EEPROM parameters and status variables which may then be used in the
application code (they will appear in the section Project>Global Shared) and allows you to construct the menu Prg
(Programming), the menu Set Status!® and Alarms of the FREE Smart/Evolution target as well as the interface of the current
project, which will be displayed in FREE Studio Device

The Resources tab includes the following sections:

MODBUS OBJECTS

This section enables you to define EEPROM parameters and variables, which can be displayed on the target, Device and read
using the Modbus® RTU protocol
For all sections, it is possible to add or remove parameters/variables in the same way as for variables in the Project tab
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EEPROM Parameters

This section is for creating the variables which the developer intends to save even if the power to the target device is switched
off.
Note: the user of parameters in the code is read-only; to write, use the appropriate functions of FREE Smart.

Status Variables

In this section we define the status variables which can be displayed in the menu of the target device.

Each variable will have a transcoding on the instrument due to the 4 digit / 7-segment display. In the Display label box, you can
select the transcoding and see a preview of how it looks on the display by clicking on the 3 dots (...)

Note: some letters will not be displayed (e.g. x and z) so there will be a blank space on the display.

If the display label is zzz, nothing will appear on the display.

If the display label is SET, SEt will appear on the display.

5 only for Smart. See Installation Manual 9MAx0036 (x = O: IT; 1: EN; 2: FR; 3: ES; 5: DE)
For Evolution the Menu is defined from UserlInterface

FREE Studio - Quick Start page 23



Panel ¢ Evolution
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EEPROM Parameters
Same as Smart

Status Variables

In this section we define the status variables which can be displayed in the menu of the target device.

Smart ¢ Panel ¢ Evolution

In the target column, only columns that are visible from the Smart, Panel or Evolution target are indicated.
Refers to both unless indicated

target

Smart

column
IPA

address

Name

display label
Device Type

Default Value /Min/Max

Format

Application Type

Panel
Evolution

Smart

Scale/Offset
Size

Unit

Access Level

Read only

Description/Note
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‘ Description
pre-assigned index
resource Modbus® address

resource name which may be used by the developer in the IEC
application code

name displayed in the application menu of the target (4-digit)
type of data displayed on target and Device

minimum/maximum default values of the resource displayed on target
and Device

display format for Default Value /Min/Max
e.g. XXX.Y display of whole number with decimal point

type of data used in IEC application code

conversion coefficients between Device Type and Application Type
Application Type = scale* Device Type + offset

Significant only in the case of STRING type. Dimension (Length) of the
string. Default and max= 31 characters

unit of measurement of Device Type displayed on Device and if
available with icon on target

See Visibility table. This column does not apply to Evolution
enables/disables editing of Status variables.

free text displayed on Device



Enums
In this section we define the types of additional variable which can be used in the Device Type!¢! column m

BIOS parameters
In this section we define any variations in the default BIOS parameters map which is factory-set by Eliwell

TARGET MENU

The target menu consists of a BIOS menu + an Application menu.
The BIOS menu is factory-set!”l.
The table below defines the main functions of the keys / LEDs of the target device.

key press Description
F5 short switch from BIOS menu to Application menu and vice versa
F1orF3 short navigate folders and edit values
F2 short cancel operation (ESC function)
F4 short access to set menu
F2+F4 short access to Prg menu
F1/F2/F3/F4 long managed by developer (by means of target variable sysKeyFunctions[])

The LEDs are managed by the developer by means of target variable sysLocalLeds][])

Prg menu®

In this section we define the Prg Menu and the folders/variables of which it is composed.

The Prg Menu can consist of one or more folders, defined by the developer, into which are inserted
e EEPROM parameters

e  Status variables

e BIOS parameters

® inputs and outputs

Set menu’®!

In this section we define the Set Menu and the folders/variables of which it is composed.
The set menu is created in the same way as the Prg menu.
The set menu contains the AL folder - see below.

Visibility of menu resources
The visibility of the resources created by the developer is indicated in the following table:

Access Level column visibility on Device visibility on target Notes
always visible
Always visible M VES
Level 1 YES Yes
Level 1 level 1 object assigned to a Prg or set
Level 2 Yes menu
Level 2 VED level 2
never visible
Never visible V= A\
never visible . .YES object NOT assigned to any Prg
Never visible Visible inithe folder NO or Set menu
ALL PARAMETERS

Alarms

It is possible to define alarm variables whose status must be managed by the developer.

If the variable assumes a value other than zero, the label will be displayed in the Alarms folder (AL) of the set menu in FREE
Smart

In the Evolution target it is only a Global type USINT declaration

6 see EEPROM parameters and Status Variables table

7 see installation manual

8 the elements entered in the table in this section will be displayed on Device
9 the elements entered in the table in this section will be displayed on Device
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FREE Smart configuration
From the Resources tab, click on FREE Smart to access the following panel FREE Smart Configuration.
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Using the drop-down menu you can set the value of the variable / parameter you intend to show on FREE Smart as the main
display (Fundamental state display). If you set no value (none) the message PLC will be displayed.
The values available are all the 1I/0""% + the values defined by the developer in the Set menu.

Execution time

From the same panel it is possible to set the execution time of the project in milliseconds (ms).
The default setting is 100 ms. The available range is from 20 ms to 100 ms!"1],

I1/0 mapping

In this section we define the links between variables and physical I/O of FREE Smart.
e Local: local variables of the SMD/SMC base module

e Extended: variables of the SE expansion module

e Remote: variables on the SKW/SKP terminals

TARGET MENU

The target menu must be created by means of the UserInterface.
The BIOS menu is factory-set!'? and is visible from Device.
The main functions of the keys/LEDs of the target device can be programmed by means of the Userinterface!'

Menus

In this section we define a "dummy” Menu that does not appear on the display and the folders/variables of which it is
composed.

The Menu can consist of one or more folders, defined by the developer, into which are entered

e EEPROM parameters

e  Status variables

Alarms
The alarms for Evolution are only defined to enable the portability of a Smart project.

10 the 1/0 are all the local and remote inputs and outputs, including those of the terminals. See installation manual for details
11 See also the section on Associating a program to a task

12 see installation manual

13 LEDs also programmable from Application
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FREE Evolution configuration
From the Resources tab, click on FREE Evolution to access the following panel FREE Evolution Configuration.

o _w [E—

.H (- H"—I

Execution time

From the same panel it is possible to set the execution time of the project in milliseconds (ms).
The default setting is 20 ms. The available range is from 20 ms to 100 ms!'4l.

I1/0 mapping

In this section we define the links between variables and physical /0O of FREE Evolution.
e Local: local variables of the EVD/EVC base module
e  Field: variables and/or binding of third-party controllers

Note
If correctly defined!®], all the variables defined inResources will automatically be located in the Global Sharedsection.

Panel

FREE Panel configuration
From the Resources tab, click on FREE Evolution EVP to access the following panel FREE Evolution Configuration.
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T
- —— . [Rr—
=¥ s ST e—t
[ @%
Fy=omy 3
| - —
14 See also the section on Associating a program to a task
15 the project must be saved without errors for the variables to be visible in the Project tab in Global Shared
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Execution time

From the same panel it is possible to set the execution time of the project in milliseconds (ms).
The default setting is 20 ms. The available range is from 20 ms to 100 ms!él.

I1/0 mapping

In this section we define the links between variables and physical /0O of EVP!"'7),
* Local: local variables of EVP
e  Field: variables and/or binding of third-party controllers
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Analogue Inputs
Note that the presence of the inputs depends on the model

input probe type EVP3300/C
AIL1 on-board on-board NTC v
AlL2 remote configurable NTC 103AT/NTCNK103/DI v
not included
AIL3 remote configurable 4...20mA/0-5V/0-10V v
not included
AlL4 on-board on-board %RH -

Note

If correctly defined,1"® all the variables defined in Resources will automatically be located in the Global Shared section.

16 See also the section on Associating a program to a task
17 in reality EVP has only 4 analogue inputs AIL1...AIL4 and no output
18 the project must be saved without errors for the variables to be visible in the Project tab in Global Shared
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SAVING PROJECTS

Once you have completed the project you can save it in various forms and send it to third-party Developers or Users.

File types
Target File type Application
Smart .PPJS Application
Panel .PPJS Application
Evolution Connection
.PLL Application
.RSM Application
Panel PAJX User Interface
Evolution
Panel .PPJX User Interface
Evolution
Smart .CFN Device
Panel .CFN Device
Evolution

Description

Project created with Application to be opened with Application

Project created with Application that can be added to an Evolution/Panel
device with Connection

Library created by the developer to be used in Application or Device
Compressed .PPJS project

Project created with UserInterface to be opened with Userinterface

Same as .PPJS. Shared projects

Project created with Application to be opened with Device
Note. The source code is not available but the project can be downloaded
to the target device

Project created with Application or Connection to be opened with
Device. If the device is created with Connection it will contain both the
PLC application and the HMI menu

Note. The source code is not available but the project can be downloaded
to the target device

TRANSFERRING PROJECTS AND FILES

The table below shows several operations involving the transfer of projects from one developer to another or from a developer
to a user. The data transfer involves the sending of one or more files defined in the previous section

Project

The developer wants to transfer a project to
another developer.
The developer sends a .ppjs file

The developer who receives it can open and
edit it with Device Application; The developer
connects to the target, and compiles and
downloads the application.

The developer sends a .ppjs file to another
developer

The developer who receives it can open and edit
it with Application; The developer connects to
the target device and compiles the application.
After compilation, the developer selects the
menu heading Developer > Open with FREE
Studio Device and configures the target device
BIOS (parameterisation of the target device)

From -->To Application File type Notes
Developer Application .PPJS

v
Developer
Developer Application .PPJS

Device

v

Developer
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Project From -->To Application File type Notes

The developer wants to transfer a project to a Developer Device .CFN From Device the user
user CANNOT compile the
The developer sends a .CFN file v application

The user who receives it can open it with User

Device; The user connects to the target device,
downloads the application and configures the
target device BIOS (parameterisation)

The developer wants to debug an IEC Developer Application project
application already present on the target device folder
but does not have the source code. v

The developer receives the entire project Developer

folder (which includes the binary files and
debug symbols) used for downloading the [EC
application onto the target device.

Note: the project has not been modified

(no modification to the source and no
recompilation and/or download)
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CONNECTION

To download the IEC applications of Studio from the personal computer to the Smart target device, several additional modules

are necessary.

The tables below show possible operations:

Multi Function Key/DMI

Multi Function Key

PC> € MFK MFK > € Smart PC>
e Sl g
@M Mutti Function Multi Function .
"&"* Key Key art e

use blue TTL cable
for DMI - MFK connection

Use yellow TTL cable
for MFK - target connection

Use yellow TTL cable
for DMI - target connection

Data‘::lvc:IZ:ding 2 € Data‘::vc:IZ:ding 2 €
Parameter map - Parameter map v v
IEC application v - IEC application ‘ v ‘ -
BIOS v - BIOS v -

Note: in "Direct” Smart must not be connected to earth
For a complete description of the use of the MFK, refer to Application Notes MFK code 91S24233 EN-IT

To download the IEC applications of Studio from the personal computer to the Evolution target device, several additional

modules are necessary.

The tables below show possible operations:

direction
. > €
Data downloading
Parameter map v v
IEC application v -
BIOS v -

Note: connection via ETHERNET requires the specific EVS plugin module

USB Host USB device USB-RS485
USB > € Evolution PC > € Evolution USB-CANOpen
ETHERNET
PC> € Evolution
USB -=_-.‘ RS485 --
l — USB/Rs485
e D R
lﬁ i 5 -
R
P USB/CAN R Evolgon
" direction
direction > €« F o
Data downloading > €« Data downloading ” ié% L -
A FREE Evolution
Parameter map v v Parameter map - - el oo + Plugein ETH
IEC application v | v IEC application direction > €
H— UM apolication ‘ Data downloading
HMI application v v PP Parameter map 4 v
i v v Data fil
Deir il atafres IEC application v -
BIOS v | - | BIOS |- :
HMI application v -
Data files v v
BIOS v -
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Panel

To download the IEC applications of Studio from the personal computer to the Panel target device, several additional modules
are necessary.
The tables below show possible operations:

USB-RS485
USB-CANOpen
ETHERNET
PC> € Evolution

[T
[

¢ ETHERNET s
L) i
directi
irection . 5 €
Data downloading

Parameter map v v
IEC application v -
HMI application v -
Data files v v
BIOS v .

Note: connection via ETHERNET does NOT require any additional module
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DOWNLOAD IEC APPLICATION ONTO TARGET

Connection and application downloading operations for Smart and Evolution are different.
The connection procedures are illustrated below (see relevant paragraph)

e Network for Smart

e USB-R85 for Evolution

The actual download adopts the same procedure for both targets

Smart

PRELIMINARY OPERATIONS

In order to download the application correctly, the user must:
1. connect the DM hardware interface to the PC.
2. Make sure that the driver has been installed - see DM interface Set-up.

COM settings!"

From the drop-down menu, select Communication > Settings
The COM port must previously have been read/set in “Peripherals Management” (see Reading the DM interface COM port) for
it to be recognised. If there are errors, refer to the paragraph “DM interface connection error”.

Device Link "anaper Conflg w10 x|

Cumeni selachad proioced | Ewlin

Pactocols | Active |
T Carlpin

T EwDMl Bctive

T Modbus

¥ ModbusTOP

Deesplan
Elsell DI

e |

For Smart select EWDMI or Modbus!2. If the protocol is not activated press the Activate button
The value selected for the COM port will be saved and will reappear each time the program is accessed, until it is changed.
The properties are visible and can be edited from the panel Communication > Settings > Properties"!

D8 Lonkguration vl 3 2
[ —
Pori CoMa -
Bmakals ET
e T

© Predocal sengt 1
fukhraa |1
Tirremna |1I'.I'I.'|

] e

the COM settings must be set on all of the workspaces: Application, Device and UserInterface
in the case of Modbus for /S models only with maximum speed 19200 baud. TTL not for use.
obviously, the protocol must be activated beforehand

WN =
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DM interface connection error

Error opening serial port

If the “Error opening serial port” message appears, proceed as follows:

1. Check that the COM port setting in the program is the same as one read in the COM port reading by the DM interface.
2. If they are the same, physically disconnect and reconnect the DM interface from the USB port. This should make the
operating system recognise the interface.

3. Repeat the DMI Detection function.

SMART TARGET

Smart has certain parameters in the CF folder for managing the connection between the target and Studio

If the target is "empty”!4, e.g. there is no IEC application on the device, Smart will display the message FrEE:

g il

e - o
F5 - r
@ Frét g

3 000006 F4
To view the parameter menu, press

the Esc and Set keys at the same time.
This will open the PAr menu.

F1 disall [[ [free [
esc P_‘
P Ar .
F3 5000660

The parameters menu PAr contains all
controller folders. Press the set key to
view folders.

g vl [ [ free [,
i R esc
Fs '- . Prg
L L I' e I
F3 @ Qe®OO®O® F4

The first folder shown is the CF
configuration folder. Press the set key
to view the folder parameters.

[] [free IS

esc

q_ F 'lu m
L i)
. . T oem

F3 (D@@@@@@ F4

H <livll

The first parameter shown is CF30.
To view the value of the parameter
press the set key.

(||| free IS
' . 1

Prg

J
vvv-

B 0000000 F4

1 <ivall

Use the UP and DOWN keys to change

the value if necessary. To confirm the
value press the set key.
To exit press Esc

[] [ree IS

o <livall

B 0000000 4

Use the UP and DOWN keys to scroll
the other parameters and repeat the
procedure to view the values and -
if necessary - edit them.

Parameters needed for correct connection between the Smart target and Studio.””

parameter description values default visibility notes
CFO1 select COM1 (TTL) protocol 10==NI|E(I)ILV§HS 1 2 Must be set to 1
CF30 Modbus protocol controller 1955 1 3
address
0,1, 2 = not used
- Check that the set
43;199620000bbaauud d values correspond to
CF31 Modbus protocol baud rate 5 — 38400 baud 3 3 those defined by the
6 = 57600 baud c panel
7 = 115200 baud ommunication >
1= EVEN Settings > Properties
CF32 Modbus proto.col controller 2 — NONE 1 3
parity 3=0DD
4 otherwise (IEC application exists on Smart) the message PLC will appear on the display.
Simultaneously press the UP and DOWN keys to view the message FrEE
5 for other parameters and to manage visibility levels see the Smart installation manual
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Evolution

COM settings!®

The settings are identical to those given for Smart:
panel Communication > Settings
For Evolution EWDMI must NOT be selected

e Select CAnOpen in the case of USB/CAN connection
e Select Modbus in the case of USB/RS485 connection
e Select Modbus TCP in the case of Ethernet connection using the relevant plug-in

If the protocol is not activated press the Activate button

o e Lok Manaver Contig vt ST

Cument selachad pesiocol | EwDIE

Pactocols | Active |
¥ Calpen

T EWDuI At

T Hodbuz

¥ ModbusTOP

Dpplean
Essell Q1R

—

Also in this case, the properties are visible and can be edited from the panel Communication > Settings > Properties.
Communication > Settings > Properties!”. The panel displayed depends on which protocol is activated:

T
1 m Upem Lovsteg e1002 e '
Pen  [cwzEy w e
Lo T TR |
-
LI :E”" ‘I s
- —
Prygzead 7 i i e TR
F i
Ao [0 -
T |10 -
| T

CANOpen ModBus

Modbus TCP

Corrnpmaior
¥ o sl |©2 00100
Pt o=
Pl

ModbusTCP/IP

The IP or Hostname field is for entering either an IP address (the default setting for Evolution is 10.0.0.100) or a

hostname on a local network if the router (static IP) is configured accordingly

The TCP/IP communication Port field is set by default to 502

6 the COM settings are valid on both Application and Device
7 obviously, the protocol must be activated beforehand
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MODBUS TCP/IP

=y
o e

e —— ————— |

[ ey

EVOLUTION TARGET

Evolution has a number of BIOS parameters for managing the connection between the target and Studio but, unlike Smart,
it does not have a default menu shown on the on-board or remote display!®l.

Therefore in order to view the parameters you need to open Device
Parameters needed for correct connection between the Evolution target and Studio!”:

Connect the PC Ethernet cable to FREE Evolution
Double click on the PC icon at the bottom to the right
of the application bar.

Select TCP protocol and click on Properties
Configure the Ethernet port of your PC with the
address shown in the picture (10.0.0.101). Note:
The default Evolution configuration is 10.0.0.100:
the PC Ethernet port will thus be configured

with an address different to the default address
(e.g. 10.0.0.101, the first 3 fields must be the same,
the fourth different)

Click on ok: the PC is configured to dialogue with
FREE Evolution via the Ethernet port.

The two protocols available on-board are shown. For the protocols available on the plug-in module, see the installation manual.

On-board RS485

parameter description values default notes
0=9600 baud
Modbus protocol baud ;j;gigg Eauj
Baud_RS485_OB rate - au 2
On-board 3=57600 baud
4=76800 baud
5=115200 baud
The actual address is
Addr RS485_OB On-board RS485 serial 1. 255 p dete.rmlned by the sum
address of this value + the value
of the DIP switch
On-board RS485
. 2 = uNET
Proto_RS485_OB protocol selection 3 = Modbus/RTU 3
Databit_RS485_OB | |>48° data bit number 8 Fixed at 8
On-board
. On-board RS485 stop 1=1 stop bit
e e bit number 2= 2 stop bit !
0= NULL
Parity_RS485_OB Clrberie) [REAE5 1= ODD 2
protocol parity 2— EVEN
8 Eliwell provides examples of HMI menus for configuration of BIOS parameters
9 for other parameters see the Evolution installation manual
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On-board Ethernet

parameter description values default notes
2=500 Kbaud
3=250 Kbaud
CAN protocol baud rate 4=125 Kbaud
ZLUL Ll e On-board 5=125 Kbaud 2
6=50 Kbaud
The actual address is
Addr_CAN_OB On-board CAN serial 127 1 dete.rmined by the sum
address of this value + the value
of the DIP switch

PASSIVE ETHERNET PLUGIN
For the protocols available on the plug-in module, see the installation manual.
Here, we note only the following points:

Note:

The ETHERNET passive plug-in configuration parameters involve the configuration of the TCP/IP communication port (e.g. 502),
the IP address, the gateway and the subnet mask
The “Default Gateway” and “Net mask” parameters are of no significance in the local point-to-point network.

For connections via a router the "Default Gateway” parameters must match the IP address, as in the following example:

range
parameter description default /value\ parameter description (IP & default |/ value
Gateway)

Ethernet passive Plug-

Ip_1_ETH_PI i 10 | 192 De;?:l“’;;"— Def?;ﬁ G::te)way 0_255 | 192 | 192

IP address (1st part) - P

Ethernet passive Plug- DefGtwy_2_| Default Gateway

IpR2sEREE inlP address (2nd part) 0 o3 ETH_PI (2nd part) 0_259 ce es
Ethernet passive Plug- DefGtwy_3_ Default Gateway

[t LA in IP address (3rd part) 0 \ 0 ETH_PI (3rd part) 0_259 0 0
Ethernet passive Plug- DefGtwy _4_ Default Gateway

R in IP address (4th part) 100 \0(/ ETH_PI (4th part) U_259 ! E

COM settings

The settings are identical to those given for Evolution:
e Select Modbus TCP in the case of Ethernet connection!*®

TARGET PANEL

Panel has a number of BIOS parameters for managing the connection between the target and Studio

The default display menu (DIA menu) A) can be viewed by simultaneously pressing the UP and ESC keys
The default display menu only shows the parameters for the CAN protocol
Therefore in order to view other parameters you need to open Device

The available on-board RS485 and CAN protocols are the same as Evolution.
The table below shows the Ethernet protocol parameters

On-board Ethernet

parameter description ‘ range default notes
IP_1_ETH_OB Ethernet passive On-board 0. 255 10 default
IP address (1st part) ETH: 010.000.000.100
Ethernet passive On-board
IP_2_ETH_OB 1P addross (2nd part) 0..255 0 MAC address
Ethernet passive On-board (e.g.: 0,1,2,50,60,70
IP_3_ETH_OB 1P adddrose (3rd part) 0..255 0 IP address
Ethernet passive On-board (e.g.: 192,168,0,150)
IP_4_ETH_OB 1P adchoss (4th part) 0..255 100

no additional module is necessary
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HMI management

In addition to the BIOS parameters, Panel manages the HMI menu

HMI management

parameter

description

values

default

notes

Hmi_language

Display language

(local or remote)

0_ 65535

0= Remote HMI 1
1= Remote HMI 2
2= Remote HMI 3
3= Remote HMI 4
4= Remote HMI 5
5= Remote HMI 6

Local HMI is identified
on the display as
Network
In Connection as HMI

HMIList_current Current HMI 6= Remote HMI 7 11 Remote HMI is
7= Remote HMI 8 identified
8= Remote HMI 9 In Connection as
9= Remote HMI 10 Remote HMI
10 = not used
11= Local HMI
Remote HMI
Ten remote menus are available. The menu 1 parameters are listed below. The others are the same
parameter description values default notes
HmilList_ID_1 Remote HMI 1 navigation ID list 0_254 0
1=RTU
- Remote HMI 1 navigation resource (RS485 Modbus RTU) _
HmiList_Res_1 type 2-TCP (Modbus TCP) | >~ AN
3=CAN (CANopen)
Remote HMI 1 navigation resource
HmilList_Addr_1 address for CAN, RTU and TCP 0_255 0
(IP part 1)
A Remote HMI 1 navigation resource e.g. CAN: 2. 500000
Hmilist Addr_2 ™ e TCP (P part 2) Yo 0 e.g. 485s: 1. 38400. P81
- Remote HMI 1 navigation resource ETH: 010.000.000.100
Ll el address for TCP (IP part 3) 0_255 0
HmiList Addr 4 Remote HMI 1 navigation resource 0_ 255 0

HmilList_File_1

address for TCP (IP part 4)

Remote HMI navigation file 1
(DOS 8.3 uppercase format)
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CONNECTING TO THE TARGET
Before connecting, the bottom right of the screen displays the message NOT CONNECTED
From the drop-down menu select Communication > Connect

If connection is successful, the following screen (minimised) appears in the menu bar:

[ sntn
Temige [T
Hom o amw ]

g | - |

This screen will remain present as long as the target device is connected. To interrupt the connection, repeat the
Communication > Connect procedure

At the bottom right of the panel is a connection palette divided into 3 sections
Before connecting to the target the panel shows that there is no connection

| EDIT MODE | | NOT CONNECTED

When connected to the target there are various situations shown below

| EDIT MODE | DIFF. CODE CONNECTED

e CONNECTED (in green): if the connection is established and the target application coincides with the Studio application
e CONNECTED (in yellow): if the connection is established and the target application does NOT coincide with the Studio
application

| EDITMODE | NOCODDE CONNECTED

e CONNECTED (in green): if the connection is established
e NO CODE (in light blue): if the connection is established and there is no application on the target

| EDIT MDDE SOURCE DK CONNECTED

e CONNECTED (in green): if the connection is established and the target application coincides with the Studio application
e SOURCE OK (in green): if the connection is established and the target application coincides with the Studio application

e ERROR (in red): if there is a communication error

DOWNLOAD

To download the application, simply press F5 or select Communication > Download code from the drop-down menu
The following dialogue boxes will appear

A. If the application is already present, you will be asked for confirmation to overwrite the previous version
B. Warning message that the PLC will be reset on the target

A B
it o it mppaton i 15—t 1 ere St Appmstim =i
‘_E_, -#;-ﬁh-*-ﬂ-"hw-- _ﬁ P ol o 1 T i, e |

] = | | == o i85

If you confirm with “Yes” the application will be downloaded to the target. The process may take a few seconds: the “Download
in progress” window appears to show the status of the download.

In the event of a connection error, the following dialogue box appears:

114 1 e e A st

|l T T T (TR
Chalwis T’ i Do i
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DEVICE PANEL DEFINITIONS [[] [free|
Smart

The Device workspace is shown below with screenshots and descriptions for Smart. Where necessary,

the differences compared to Evolution are highlighted.

The Device workspace has various sections for managing an IEC application generated by a developer,

e.g. FREE Smart parameter configuration, testing, BIOS updating and application downloading to the target device.
Note: the source code of the application is NOT visible from Device

The sections (panels) are listed below:

R R T T e —

This section shows the work tools in the form of icons.
To display or hide the toolbars, simply right-click and
Configurator bar select or deselect the desired tools.

Some tools can be selected by means of key
combinations (shortcuts).
See relevant chapter for details
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Section

H*

*panel not visible at first start-up.

Panel Name /
Application

Section

Project

Catalog

Connection
Status

Watch

Oscilloscope

Output

Panel

Project

Edit panel

Applications catalogue

Display variables with
application running

Display variables graph

Messages

Deé

The Project panel enables you to manage one or more
FREE Smart devices.

Description

According to the selection made in the Project panel, the

following appear in this section:

e  BIOS parameters (parameters + 1/O values)

e  parameters and variables defined by the developer in
Application associated to the menu

This panel shows all the applications available from the
catalogue

This panel shows the connection status of all the targets in
the Project panel

This panel enables you to manage variables debugging
by displaying their status in number/letter format when
the application is running and connected to the target
device

Like the Watch panel, this panel enables you to manage
variables debugging by displaying their status in graph
format when the application is running and connected to
the target device

This panel shows the messages relating to the
development of the project (file opening, reading/writing
errors, status of connection to device, etc.)

Note: the connection to the target device is also visible
in the bottom right of the screen by means of coloured
messages (see Application Download)

To display it, simply check the heading in the drop down menu View > Output

The panels appear or remain hidden (see Shortcuts) and can be organised as the user wants in terms of size and layout.
Studio saves the last settings made
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FIELD OPERATION [|| [free

Smart
FIRST START-UP=

1. Click on the Launch FREE Studio icon on your Desktop
2. Click on the FREE Studio Application!? icon.
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The program appears as shown in the picture:
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You can now:

e Create a new project .CFN “New Project ..."®!

e  Open an existing project “Open project ...”

e  Open recent projects “Most recent projects ...” by selecting from a list

Device projects have the extension .CFN
In the same project, you can add more than one drive and associate to each drive an I[EC application created with Application

1 the Device tool is available for Smart. All tools (including Application) are available for Evolution. For Evolution you are advised - for First Start-
up - to always start from the Connection tool (see relevant chapter)

2 a project can also be opened with Device from Application from the drop-down menu Developer > Open with FREE Studio Device

3 for a new project, you must add a drive listed in the catalogue by right-clicking and selecting Add. See next screenshot.
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A new Untitled project is empty. Simply right-click to add a new drive to the existing project in the catalogue by
selecting Add.
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OPENING THE IEC APPLICATION

In the same way you can add the respective PLC IEC application present in the catalogue.
The catalogue can contain various applications but only one can be associated to a project
The IEC application will be added to the drive with name_1
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Existing projects can be opened as described previously or directly from Application:
the menu Developer > Open with free Device will start the Device containing the project created by the developer with the
development environment Application.
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CONNECTING TO THE TARGET DEVICE

Device requires you to connect to the target device again (click on the respective icon). The central panel shows the
protocol references, address, etc. The default name of the target device is FREESmart_1141.
When the target device is connected, you can read or write parameters.

READING PARAMETERS"!

By default, the project contains a list of the BIOS parameters and I/0 values!®! with their respective default settings.
From the target device, the user can read all or just some of the parameters!”!

Suppose we want to read all the parameters.

From the drop-down menu Parameters>Read all device parameters it is possible to read all the parameters of the connected
target device.

The operation takes a few seconds.
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If there are configuration parameters which have default values other than those present on the target device, they will be
highlighted in an appropriate colour (blue®)

WRITING PARAMETERS

The user can download all or some parameters to the target device, either with their default values or with modified values
inserted by the user.

Suppose we want to download all the CL parameters (local BIOS) and no others.

Select all the parameters - drop-down menu Parameters>Select all (CTRL+A) or using the respective icon. The parameters are
all highlighted in yellow. Write drop-down menu Parameters>Write selected (CTRL+SHIFT+W) (or using the icon W).

All the CL parameters will be downloaded to the target devicel®.

As explained in the notes, you can also download the values of the I/O variables set by the user or their default values.

4 by simply using the copy/paste function, you can create a twin project FREESmart_2, change the BIOS parameters and download them to the
target device or a second target device

5 in reality, in this case, the term “parameter” refers to any resource present on the target device, in other words genuine parameters in their own
right, 1/0 and variables of the application present on the target

6 the default value of the analogue inputs and outputs is 0.0; the digital inputs and outputs are set to FALSE

7 to read a parameter, simply select it with the mouse and click on the icon R.

You can make multiple selections (CTRL key for non-adjacent selections, SHIFT for selecting a part of the block)
You can select the entire block by clicking on the respective icon.
The selection is highlighted with a yellow background

8 see parameter values table

9 see the specific chapter containing project development examples
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present on the target device with the values listed in the Value column.

Downloading all the parameters (drop-down menu Parameters>Write all device parameters!'?) replaces all the values
= |
Note: the inputs are read-only and are shown in grey. See the following table:

Parameter values table

colour column description cases
black value value aligned with default  target already read

default column value different

blue default . target already read
from value in value column
lue NOT ali ith .
Vel MOV liigmeel wl e Device just opened
red value default
e value changed by user
I |
read-only 1 values
grey name . analogue inputs Al
P digital inputs DI
green name priEmEtes et viElsla en See visibility table

target display

When declaring the status variables and EEPROM parameters in Application you can also define their level of visibility in the
Smart target!' menu as shown in the figure:

8 & gy v | i Py s

BIOS Download

The user can also upgrade the Smart BIOS from Device. Select the name of the target and click the right mouse button. Select
BIOS download and open the .fwf file that you want to download.

The Direct!'? mode is executed via DMI directly on PC whereas the MultiFunctionKey mode requires passing through MFK and
then downloading onto Smart.

The default BIOS menu of Evolution is visible from the folder All Parameters.

In the All Parameters folder you can also view user parameters defined with Application

Downloading the PLC application and the HMI menu is only performed from Device but is described in the Connection
chapter

The default BIOS menu of EVP is visible from the folder All Parameters. In the HMI management folder you can view the
parameters for managing local and remote HMI pages.
In the All Parameters folder you can also view user parameters defined with Application.

10 if you select Parameters>Write all default values, all the default values including 1/0 will be downloaded to the target device
11 has no effect on Evolution
12 see installation manual. BIOS Download not available via RS485.

Do NOT power up Smart externally (only power up via DMI)
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USER INTERFACE PANEL DEFINITIONS [|| [free

Evolution U I

The User Interface workspace dedicated to developers features various sections for creating and managing
customised pages, e.g. defining the graphical interface of FREE Evolution, using and creating templates and downloading HMI
onto the target device.

The sections (panels) are listed below:

§ o] hoveariln e Lol | e]ESE

Y Y

-

Panel

The User Interface workspace for EVP requires that page creation and management and local HMI downloading occurs on EVP
The characteristic of EVP is that it manages Evolution remote menus created with UserInterface

The menus that EVP will use as remote HMIs must be created specifically as such .. e
See Creating a new project. [
i |
bty TE L%
P |,::= =h |
il -

=l
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Section

H

Panel Name /
Section

User Interface

Project

Actions

Document bar

Properties

Output

Target vars &
parameters

Templates

Panel

Configurator bar

Project

Edit panel

View properties

Messages

View target variables and
parameters

View available templates

The panels may be visible or hidden at first start-up.
To view them, simply check the relative heading in the drop-down menu. For example: View > Templates
The panels can be organised as the user wants in terms of size and layout.

Studio saves the last settings made

Description

This section shows the work tools in the form of icons.

Some tools can be selected by means of key
combinations (shortcuts).
See relevant chapter for details

The Project panel is divided into 2 tabs:

®  Project: for managing the pages that will be shown
on the Evolution graphical terminals

e Resources: for managing images, lists and strings
that may be used in the pages

According to the selection made in the tab, the following
appear in this section:

e Local Actions

e Global Actions

actions linked to the User Interface keys

This panel is used to configure the graphics of the pages

This panel is used to define the properties of the pages or
of their constituent elements

This panel shows messages relating to the development
of the project (file opening, compilation errors, etc.)

The panel is divided into 2 or more tabs:

e Target vars contains the variables/BIOS parameters
of Evolution

e  PLC vars contains the variables/parameters defined
in the PLC application of Application installed in
the Evolution base module where the HMI will be
downloaded.

e  Other tabs display variables/parameters with Modbus
address to be shown on the HM interface. Note:
these applications have been downloaded using
Studio onto other Evolution modules connected in
a network to the Evolution onto which the HMI that
you intend to develop will be downloaded

This panel shows all of the pages created as “templates”,
e.g. as reusable models available in the catalogue
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TO START USER INTERFACE [|| [free

Panel ¢ Evolution

USERINTERFACE VS CONNECTION

As already mentioned in the TARGET chapter and as described in the Connection chapter, Userlnterface is typically opened
from Connection by clicking on the HMI node.

You are therefore advised to read the Connection chapter before developing a menu in Userlnterface.

To get started and create a simple stand-alone menu!"! follow the outline illustrated below.

FIRST START-UP

1. Click on the Launch FREE Studio icon on your Desktop
2. Click on the FREE Studio User Interface icon.

dlivll
IR studio
vsen wrenonce |

1 2

The program appears as shown in the picture:
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1 a menu created in this way is subsequently linked to a Connection project. See corresponding chapter.
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You can now:

e Create a new project "New Project...” - CTRL+N U l
e Open an existing project "Open project ...” - CTRL+O

Existing projects have the extension .pajx

CREATING A NEW PROJECT

e Click New Project ... or
e select File > New Project (CTRL+N) from the drop-down menu

The dialogue box shown below appears, in which you can create, name and save a new project:
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New Project New remote HMI

The new project appears as shown in the figure:
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e Adescription of the icons is available in the Online Help (in English) - see “Support”
e The standard development environment described previously is developed in this chapter

The pages that follow explain how to create, develop and test a new menu, with simple examples of pages, templates and
elementary programs.
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CREATING PAGES

All of the created pages that will comprise the menu shown on the instrument display will appear in the Document bar panel.
Below is a general description of the elements used for creating pages
The Appendix gives a number of simple examples of menus that you can use to define a basic working menu.

PROJECT PANEL/PROJECT TAB

In this tab the following elements (nodes) can be used:

e Pages for managing pages (create, delete, import/export etc.)

e Messages for managing message pages

e Global variables for managing “variables” common to all pages

e Global procedures for managing “procedures” common to all pages. Note: procedures are written in ST language only

PAGES

Properties
From the Project tab, Pages node, by right-clicking on Properties you can edit the properties of pages, "as indicated:

N i N i ErTTTEE———— i
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General System options Language selection

—

From the General tab you can select which page to set as the initial page
2. From the System options tab you can select the type of font!?, the text colour and the background colour (choice of black
or white)
3. From the Language selection tab you can manage the language settings:
e click Select to choose the current language (indicated in the Current language box),
e click Add to add a new language
e click Delete to delete a language
e click Export to export and import the .txt text file to be translated!!
e click Import to import the translated .txt text file!4]
4. from the tab Global On timer the developer can add specially created global “on timer” procedures

Creating pages

Using the drop-down menu, select Project > Objects (insert page) or click on the respective icon New Page

A window will open where you can insert the name of the page!®. The created page appears in the Document bar section
(where it can be edited and changed)

Note: the page can be set as a pop-up!®! page.

these properties are not those of the individual page but are common to all pages

also visible from the tab Resources > Fonts

and from the drop-down menu Project > Export language to file...

and from the drop-down menu Project > Import language from file...

the page name must not contain spaces (e.g. New Page returns an error; NewPage (with no spaces) or New_Page (with underscore) are
acceptable

names. No other characters are accepted (E.g. /, <,>, etc)

6 only one page is shown on the display at any one time. A pop-up page is a page that is appears on top of another page

ABRWN=
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Initial page m

The property of “initial” page must be assigned!”!

The initial page can be the page used for the “fundamental state display” e.g. the default page that appears when the
instrument is not in use. The fundamental state display can therefore be an image!® (e.g. logo or company name) or a page that
displays important values (e.g. temperature, pressure, setpoint etc.) for easy reference

Note: if the initial page is not set, a compilation error will be returned.

Managing pages

Click the right mouse button to rename, copy or delete a page, etc.

T sa sESSAD
a . TELET
e e — =
[ P e B ruaes i e rarows g
| —— ]

e |

——u ™ Pooru

— |

[ o ] cocd |
L _Ir LT | .
Insert page New page
Messages

From the Project panel, right-click the Messages node and select Insert new message page to create a new message pagel®.
Message pages are similar to other pages but each one bears a unique ID

Below is an example of a "message” page call with syntax

Call from a User Interface script: dummyboolean:=Video_SendEvent(kWM_MSG, MessagelD)

Call from an Application program: dummyboolean:=sysHmi_Message(MessagelD).

Proyet »
T Mewd ITPreanct Progect rr= T
frorm iessage page "3“‘“ -
Insert B ruieae ol bhe o pagn. Missage 1D F -
Ihlmﬂr-u..m-'nﬂ |r T - e
Lol varasbie g 1 |
I P F Lol procedures
= ] heMessagerage I
[ ok | Canca | ) Local vanables
F Locd prodedores
#]- ] shobesl werisbies
F Fobel procedures
Message page example of message pages tree example of message 1 page

Template

From the Project panel, by right-clicking on a page you can export the page (ending in .pex), or select Export page as
template to save the page as a template page!'®. (ending in .petx)

From the drop-down menu Project > Template management you can manage templates by adding .petx pages to the
Template List. The added pages will also appear in the Templates panel as a library and can be used by dragging and
dropping them in the project, creating the desired template from time to time.

it can be modified from the Pages section (node). The initial page is identified by a “play” icon (red triangle).
technically known as a “splash”
identified in the tree as a Warning triangle on a yellow background

0 a template is a model or form that must be compiled based on a predefined structure

= 0 00N
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PROPERTIES PANEL

Every object that will be drawn on the page has properties that can be set from the Properties tab.

Depending on the object selected from the Page bar in the Properties tab, the elements required to correctly manage the
object on the page will be shown or hidden

The complete list can be consulted in the Online Help. The most frequently used ones are listed here.

PROPERTIES TAB!""
Each individual page has properties listed as follows:
Default Description Default Description
CharDimX 6 Defines the page Title bar NO Inserts a tltle. e
. ) preset width
grid guides
min(1,1) for
CharDimY 8 positioning the Page border NO Inserts a page
objects border
] , defines the content
*
Font EWP2_8x16 character size Caption of the title bar
Back color “white"” EeE groling Appearance Flat CIBiITEs NS e
colour border
Text color “black” text colour

Each time that these fields are modified, an asterisk (*) appears next to the name of the page.
To save the change, always use the RETURN key.

ACTIONS PANEL

This panel enables you to define the “actions” assigned to the Evolution keys for navigating the menu on the display.

Actions are divided into

e Local Actions: actions that are specific to the individual page concerned

¢ Global Actions: actions that are common to all pages in the menu/project

Evolution has 4 keys: Right, Left, Up, Down and Enter. You can also associate an action to a long press of each of the 4 keys!'?
(identified by the prefix Long, e.g. LongUp).

In addition to the 4 keys there are 10 virtual keys identified with VK_F1, ..., VKF10!'3!
The virtual keys are associated to a procedure written in ST language.

11 do not confuse with the corresponding item “Properties” in the Project tab, Pages section (node)
12 long press of about 3-5 seconds
13 also see Userinterface manual (Online Help)

FREE Studio - Quick Start page 52



For example, suppose that we want to set the time of the RTC clock. We create the relative page

We associate the page to a virtual key VK_F1 (Close) in Local Actions.
The procedure in ST language is as follows:

sysClock update := TRUE;

uint ret := Video SendEventM (kWM KEY, kKEY VK_F1);

To insert an action, click the right mouse button and select Insert action. The selected action is highlighted yellow.
Select Remove action to delete the action highlighted in yellow
The following actions can be associated to each key

Action column Description Notes
to call a procedure simply write in the
Call call of a procedure Link column the name of the procedure
you want to call
write in the Link column the name of the
OpenPage opens a page
page you want to open
air with the relevant key. Note:
Close closes the page P ) y
automatically returns to the start page
NextField moves to the next value in a field
PrevField moves to the previous value in a field
: enables you to edit, e.g. write a value in
Edit :
a field
14 the standard functions predefined as VideoSentEvent, etc. (to be handwritten) are described in the Userinterface manual
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APPLICATION PARAMETERS

From the menu Project > Parameter management!'®! you can link the parameters of an application developed in Application
) g y P Pp p PP

Note:
Id=0 is reserved for EVK1000 or links between

e I =
L]
— . L a UserlInterface project and an Application
il that reside on the same hardware

* |d#0to be setin the event of a connection
to an external device (i.e. displaying data
from another device or from hardware other
than the target on which the UserInterface is

O | executed)

Click Add Device to import the desired parameters file (.parx). Modbus or EWDMI"¢! or Modbus and CANOpen!'”! addressing
can be associated to each set of parameters.
The set of parameters will be shown in the appropriate tab of the Target vars and parameters panel

PROPERTIES TAB/VARIABLE

To use the variable, drag and drop it from the imported tab into the pagel'®

The properties of the variable will be identified in the Properties/Variable tab with the “@ syntax”

The variable will be identified with @file namel'?.variable name

To modify it simply select the Variable field, move onto the box and click on the three dots (...)

The Variable parameter selection window appears, which shows the available resources that can be associated to the box
Note: in the same way you can create a “progress” box and associate a variable. In this case, the status / graphic progress bar of
the variable is shown instead of its value.

PLC VARIABLES
Note: Valid only for projects with EVD/EVP target
The remote HMI target only supports the @ syntax for the use of parameters/status variables of the related Application project.

From the menu Project > Link PLC variables file you can link the variables of a PLC application developed in Application

SR Em
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Import the desired "EXP variable” file (.exp). The set of parameters will be shown in the relative PLC vars tab in the Target vars
and parameters panel.

15 or from the corresponding Parameter management icon

16 Smart

17 Evolution

18 alternatively from the menu Page>New Edit insert a box that you want the corresponding variable to be associated to
19 without extension (e.g. freeEvolution_1.plc, .plc will not be displayed)
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GENERATING DOCUMENTATION

Using the icon Generate Doc. you can create documentation linked to the Doc fields (Properties panel, Doc tab)
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Through a browser!2?! you can view the generated documentation by clicking on the link Open documentation.

the documentation gives all information relating to the project:

* number of pages

e program languages

e initial page (name of initial page)

e visual list of pages (as they are presented on the display)

Example of documentation generated using the icon Generate Doc.
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20 Internet Explorer or equivalent
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PROJECT PANEL / RESOURCES TAB

In this tab the following elements (nodes) can be used:

Fonts for managing pages (create, delete, import/export etc.)

Bitmaps for managing images to be inserted in the pages

String table for managing strings to be used in the various pages
Enumeratives for managing enumerable sets to be used in the various pages
Image lists

Sets for managing sets of strings / parameters to be used in the various pages

Bitmaps
Userlinterface can be used to import images (specifically bitmaps, such as icons, logos etc.) to be used in the menu pages.
Click on the node Bitmaps > Import bitmap. The corresponding window appears for importing the image. Click the browse

button to select the image and the Import button to import it. Example of import of free logo

— e e

il O ] -

—— —a

We recommend that you import black/white images of suitable size. The display can support an image of approximately
100x50px. The imported bitmap will be in the Bitmaps!?" node.
To insert the bitmap in a page:

insert an “image” box (menu Page > New Image or use the corresponding icon)
define the dimensions of the image from the Properties panel using XDim and YDim (e.g. 100x50px)
again from the Properties panel select the bitmap from the field of the same name

b L]
P o} o et ] M 0

ITPTT
1x

String table

UserlInterface allows you to define strings that can be used when creating pages.
Using the menu String>Insert or its respective icon Insert Record you can create an association?? between a “string” and its
corresponding description.

In the ID field the string is defined as IDS_stringnamel23.,
In the Caption field enter a description of the string.

21

23

if not renamed it will be assigned a default name consisting of the image name preceded by the prefix bmp (e.g. logofree-> bmplogofree)

technically referred to as “transcoding”

you are recommended to use this prefix to prevent the descriptions that appear on the display being confused with the transcoding in

Userlnterface
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= SR - .
By selecting the page from the menu Project/Project you can associate the desired string to a text field using the menu
Properties>Caption!?%l. The text that will appear on the display will be the text inserted in the description(2sl.

Enumeratives

Userlinterface also allows you to define strings by means of enumerable sets that can be used when creating pages.

An enumerable set is an array of values that are not necessarily consecutive. Each value is associated to a description that will be

shown on the Evolution display.

Move onto the Enumeratives node and use the menu Record>Insert or the respective Insert Record icon to create the sets

that you want to usel?¢!

Each set will be shown as a subnode of Enumeratives.

Move onto the corresponding node and use the menu Record>Insert or the respective Insert Record icon to enter the array

values.

After creating (or defining) the enumerative from the Resources tab, open the Project tab and, selecting the page / element of

the desired page, you need to associate the corresponding Enum to the Format field.

The three examples show

e definition of an enumerative CelFarEnum consisting of 2 values for defining the degrees of temperature (0=Celsius,
1=Fahrenheit).

e definition of an enumerative consisting of 4 non-consecutive values for defining USB commands (values 8,9,10,12)

e use of CelFarEnum on a page

The order of the elements can be changed with the icons Move Up A/ Move Down ¥
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definition of CelFarEnum Enum with non-consecutive values use of CelFarEnum

Image Lists

Similarly to Enum it is possible to create lists of images associated to ranges of values. The image shown on the display will

change depending on the state of the variable associated to the list.

Alist is created and a bitmap (see corresponding node) is associated to each image, indicating its reference range.

After creating (or defining) the list from the Resources tab, open the Project tab and, selecting the page/element (created with

“New animation”) of the desired page, you need to associate the bitmap list to the Imagelist field

The three examples show

e definition of a Modeimg list of 2 bitmaps for displaying Cool mode and Heat mode. The range of values is reduced to one
value in this case (0 for Cool, 1 for Heat)

e use of Modeimg on an “Icons” page, associating the Modeimg list with the animation. A state variable must obviously be
associated, depending on which the image will change

However a static bitmap must be inserted as an image via Page > New Image or using the respective icon.

24 in practice it is also possible to associate images but for the sake of simplicity we have only dealt with text fields here
25 if the Description field is empty, the string IDS_xxx will appear
26 the default name is Enum1, Enum2, etc. Select the box to change the name
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definition of Modelmg use of Modelmg

Sets

Often there is the need to create a group of very similar pages (for example a scroll menu for showing a set of parameters in the
same folder)

Userlnterface allows you to define Sets that can be used when creating this type of page, without having to replicate the page
n times.

A set is an array of strings or variables/parameters!?”!

Move onto the Sets node and use the menu Record>Insert or the respective icon Insert Record to create the sets that you
want to usel?®!

The type of set can be
e  String e.g. a string defined in a string table
e Variant e.g. a variable/parameter

Each set will be shown as a subnode of Sets.

Move onto the corresponding node and use the menu Record>Insert or the respective icon Insert Record to enter new items
in the array

Strings

In the case of a String type Set the string is selected by moving onto the box and clicking on the three dots (...)

The Resource string selection window appears, which shows the available strings!?%! that can be associated to the array
The visibility (Visible column) for strings is TRUE - not modifiable
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Variant
In the case of a Variant type Set, the variable is selected®® in the same way by moving onto the column Variable/Parameter.
The Variable/parameter selection window appears, which shows the available variables that can be associated to the array.

27 including any alarms

28 the default name is Set1, Set2, etc. Select the box to change the name

29 previously defined in the string table (see)

30 in this case the term “variable” refers to genuine variables in their own right, PLC parameters, BIOS, alarms etc.
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Using the Filter option you can filter the display of the variables/parameters

The Format column shows the default U.M. of the parameter. The user can manually associate an Enum
e  Similarly the Min Max columns show the default range of the parameter, which can be modified by the user®!
e The Text align column aligns the string to the left, right or centre.

After creating the Set from the Resources tab, open the Project tab

Previously a page was created that you want to replicate using Sets

(for example in order to manage the analogue outputs BIOS_CFG_AO)

Selecting the appropriate field, you need to associate the corresponding Set to the field Assoc_var using the prefix #, and with
the suffix (0) to indicate the first element of the array. Note: The field must be of the Edit type

(for example in order to manage the analogue outputs #SetParValCfgA0(0))

The three examples show

e definition of a Variant Set SetParValCfgAO0 of size 5 to define array of output configuration parameters

e definition of an enumerative AnaOutTypeEnum of 3 values (voltage, current, ON/OFF)

e use of #SetParValCfgA0(0) on a page (which results in the production of 5 pages that differ in terms of the configuration
of parameter SetParValCfgA0(1),..., SetParValCfgA0(5)32!

® note that the Edit field "IO Modulated” is associated by means of the Format field to the Enumerative AnaOutTypeEnum

Note that in the example there is another Edit field associated to a Set.
It is possible to use multiple Sets on the same page. You are advised to define Sets of the same size if used on the same page
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SetParValCfgAO AnaOutTypeEnum use of #SetParValCfgAO0()
31 e.g. for a parameter that defines a COOL, HEAT and AUTO machine mode it is possible to hide one or more values at Ul level even if at PLC (or
application level) there are 3 usage modes
32 note that the array starts from the value (0) whereas when defining Sets the first value is 1, therefore Set(1) corresponds to #Set(0)
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CONNECTION PANEL DEFINITIONS [[] [free|
Panel ¢ Evolution
Co

As mentioned in the previous chapters Connection is the entry point for starting to develop projects.
The Connection workspace defines the hardware structure of an Evolution project and manages the network
and data exchange protocols between Evolution (binding).
The Connection workspace dedicated to developers has various sections for creating and managing Evolution!" devices,
as well as for compiling the entire project, e.g. as mentioned in Target
e creating the PLC application using Application

defining the graphical interface of Evolutions using Userinterface

[ ]
e compiling the Build project
e downloading the project via Device

The sections (panels) are listed below: A

Tool bar This section shows the work tools in the form of icons.
(Main bar) Some tools can be selected by means of key
combinations (shortcuts).

See relevant chapter for details

The Project panel can be used to manage the project and

one or more Evolution* devices

e from the project you can manage the device network
(Network list)

e The various protocols are configured In each device
- see panel C

B Project Project (Workspace)

1 including Panel (EVP) and EVK1000 terminal. Evolution means EVD (with display), EVC (no display)
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Configuration panel (Edit)

Configuration panel

Device catalogue

Messages

Panel Name /
Section Section
Application
(o /
D Catalog
E Output
user wants in terms of size and layout.
Studio saves the last settings made

Panel Description

This section contains
e  General project management tab
e  Network list tab

Depends on the selected Evolution device
e  General Evolution configuration tab

Inside the device (e.g. Evolution EVD)

(Edit) e  PLC for configuration of IEC application developed
with Application
e HMI for configuration of User Interface menu
e CANopen for configuration of corresponding

protocol

e RSA485 for configuration of corresponding protocol
®  Plugins for configuration of protocols using plug-in

This panel shows all the devices available from the

catalogue. Note: Dynamic visibility of devices based on

selections (e.g. plugins)

This panel shows the messages relating to the
development of the project (file opening, reading/writing

errors, status of connection to device, etc.)
Note: the connection to the target device is also visible

in the bottom right of the screen by means of coloured
messages (see Application Download)

*Connection manages one or more Evolution (EVD, EVC, EVK1000 terminal) and EVP devices
Smart can be inserted in the network as a slave device via RS485
The EVE expansion module can be inserted in the network as a slave device via RS485 or CANOpen

The display of the panels can be set from the drop-down menu View > panel name and the panels can be organised as the

The panel View > Compiler toolbar 31 is an icon that is visible or hidden in the Main menu

The screens below show the various default devices/nodes available for the various targets. The devices for EVD are indicated

in the table above in section C.

EVD EVP EVC and EVK are devices available as "root” nodes of the project (see Project Panel paragraph).

Panel (EVP)
e PLC
e HMI
e CANopen
e RS485
e Ethernet

Note that there are no on-board
Ethernet plugins

F, - s

EVC
PLC
Remote HMI
CANopen
RS485
Plugins
Note that the HMI is the remote type

EVK terminal
e CANopen
Note that the only available protocol
is CANOpen
There are no plugins
PLC and HMI are inherited from
Evolution
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TO START CONNECTION [|| [free

Panel ¢ Evolution
FIRST START-UP

1. Click on the Launch FREE Studio icon on your Desktop
2. Click on the FREE Studio Connection icon.

E s

You can now:

e Add anew device to the project

e Add/remove a network from the Network list
Existing projects have the extension .con

CREATING A NEW PROJECT (WORKSPACE)

To create a new project, simply save the Untitled!™ project and rename it with a name of your choice (CTRL+S)

To add a device to the project, either click on Add new device to the project'? or simply drag and drop the FreeEvolution
icon from the Catalog panel on to the project name.

-

saving the project creates in your PC a new folder with the chosen name that functions as the Workspace
2 or from the Project menu, right-click on Untitled (or project name if already saved) > Add
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example of Add (Device)

You are advised to rename each Evolution device with an appropriate name (the default name is FreeEvolution1,
FreeEvolution2, etc.)

In the workspace you can see the name of the device and the version)!

s
A ssman
= = o L i
IF_ = E=m — o —
L s e R [ —C———
T" =in N L= ....E..'.'l:'" IR
= - ] i__=
= -
creating a new project CTRL+S adding Evolution to the project

Note example of adding 2 Evolution devices

Device catalogue

Py I L1 % asian el s W el i

ekl I Ll T Wil il TP, [ il ¢
rimed A awn (LN Anrhemid IW

iR B L L] a1 05l i i Bl [

R pn—— E |

3 there may be more than one Evolution in Catalog with different versions (to view all versions, go to
menu Options > Show all versions in catalog or tick the tick box [/ when the dialogue window appears)
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example: EVD + 2 EVK terminals
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The two keyboard EVK terminals both connect to the CANOpen node
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e =]
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e -
e
CANOpen node virtual channels virtual channels
channel1:124; channel2: 123 channel1:124; channel2: 123

The CANOpen node has two default virtual channels that can be connected to a maximum of 2 EVK1000 terminals
The default virtual channels are 124 for the first terminal and 123 for the second EVK1000 terminal
Click on ? from the CANOpen node to view the values

The default address of the Keyboard EVK_1 terminal is 127, the default virtual channel 124 and the default CanOpen baudrate

500Kb/s.
Thus, when physically connecting an EVK1000 terminal to an EVD with the default settings, simply upload remote HMI from the

EVK BIOS menu.
In other cases, such as for Keyboard EVK_2 (which has the address 126), it will be necessary to set the address 126 and the

virtual canal 123 from the EVK BIOS menu.
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PROJECT PANEL
Each Evolution device has the following resources, which are shown as nodes of the target
target workspace description what to do Notes
EVD move onto the node and click

see Getting Started

EVC PLC PLC project the right mouse button to (Application)

EVP open Application

move onto the node and click

EVD . . see Getting Started

EVP HMI menu for creating pages the right mouse button to et )
open User Interface

EVD . move onto the node and click = Gisiiling Saniad

Remote HMI menu for creating pages the right mouse button to

EVC (User Interface)

open User Interface
target device description what to do Notes

EVD

EVC " on-board Evolution serial .

EVP CANOpen as standard always available

EVK

EVD on-board Evolution serial select the Mode and add the

EVC RS485* models EVD7500 and device from the catalogue check availability

EVP expansion modules EVE75xx

EVP Ethernet check availability

EVD . optional modules available T

EVC Plugins STl check availability

* also available as serials on plug-in module
**e.g. Ethernet plug-in

You can create both PLC and HMI from scratch or import existing projects and projects from the catalogue

PLC project

From the panel Project > PLC node click the right mouse button and select Open with Free Studio Application
By default you will be prompted to save the project FreeEvolution_n_PLC

See Application for information on development. To summarise:

e develop the PLC code with Application

e create parameters and state variables of the PLC application

e compile and download application onto Evolution and debug if necessary

e close Application and return to Connection

The saved project .ppjs is located in the Connection folder / workspace.

HMI project

From the panel Project > PLC node click the right mouse button and select Open with Free Studio Userinterface

By default you will be prompted to save the project FreeEvolution_n_HMI

See User Interface for information on development. To summarise:

e develop the HMI menu or pages with Userinterface

e the parameters and state variables of the previously created PLC application link to the menu and will be visible in section
H of Userinterface Target vars & parameters

e check the connection mode, appropriately configuring the connection parameters

e compile the HMI pages and download them onto Evolution

e close UserlInterface and return to Connection

The saved project .pajx is located in the Connection folder / workspace.
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The device will be added to a list (highlighted in yellow)
Press the Reload Device List button to populate the table with the list of devices connected to the HMI project and to use the

pages remotely if so required
Remote HMI project
Same as HMI Project
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PLC Configuration HMI configuration
adding an existing project adding an existing project and reloading devices list

Download project

Use the menu Tools>Build or F7 to create the .CFN configuration file

From the panel Tools > Open with Free Studio Device, open Device

After configuring the device, e.g. the BIOS communication parameters, you will be able to download:

e PLC application

° HMI pages

e configuration file Cfg files

using the Download All button

Note: each of the 3 files can be downloaded independently from the other two by moving the mouse pointer onto the
respective icon, clicking the right mouse button and running the corresponding download.

PROTOCOL MANAGEMENT

Each protocol can be used in different ways
If Mode is Not used the corresponding device is not used

target | CANOpen \ RS485 \ Ethernet ’ Profibus
Master Modbus Master Enable Modbus Master
EVP Master (for field) (for HMI remoting (for HMI remoting (for HMI remoting and -
and binding) and field) binding)
EVD ) - Modbus Master
EVC Master (for field) Slave (for binding) (for field) - DP Slave-VO
Master
BN (for HMI remoting) ) ) ) )

For settings consult the Online Help (by pressing F1)

The catalogue will show all the devices that can be added ("appended” using drag and drop) to the corresponding protocol
and no others.

In the case of Slave and Ethernet the “Binding” device is added. To "Add a source device” the network must be set.

The maximum number of devices that can be added to the individual node is checked from Studio and indicated by means of
the relative message. (E.g. max 2 EVK on CANOpen)“.

On the RS485 protocol you can also connect generic Modbus devices.

4 see also FREE Evolution and FREE Panel installation manual
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SIMULATION PANEL DEFINITIONS

Smart Evolution

The Simulation workspace dedicated to the developer has various sections for simultaneously executing
applications and pages (Evolution) in a simulation environment without needing to have a target connected to
the PC.

Simulation can simulate the execution of

e  PLC application created using Application

e Graphic HMI interface of Evolution created using UserInterface

Execution can therefore also occur on the same PC used for development.

The IEC application can therefore be “downloaded” onto the Simulator rather than onto the physical target.

We suggest starting Simulation from Application

Below is the list of sections (panels) as it appears on the first screen (empty workspace)"
Here you need to manually connect the IEC application and/or HMI? pages to the Simulator

1 compared with other worksﬁaces (Application, UserlInterface etc.) it is not essential to interact with the Simulation window. When not in use it
can be reduced with the '# ¥ key
2 Evolution only
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Panel Name /
Section Section
Simulation
A /
B Workspace
C Target name
D PLC Project
E HMI Project
F I/0 panels
G Output window
Edit Workspace®®

from Edit > Edit workspace, click on the three dots (...) to select

Panel

Tool bar
(Main bar)

Workspace

Target name

PLC application name
name of HMI pages
1/0 panels

messages

Description

This section shows the work tools in the form of icons.
v to start [EC (PLC) Application
© to stop IEC (PLC) Application

EShow HMI window
to show/hide HMI (virtual instrument)

= Show 1I/O panels
to show/hide the I/0O panels

L
¥ 1 Show full control window
to reduce/expand the window

file with the preselected name that functions as a
workspace

You can create multiple workspaces with different
applications (Smart+Evolution) and/or HMI pages
(Evolution)

Not modifiable by the user. Examples:

e FreeSmart 412.5 for Smart target

e FreeEvolution423.5 for Evolution target

Note: check from Application >Project > Select target
that the version number in the target name is equal to or
higher than 5 (e.g. FreeEvolution423.5).

if field is blank, from Edit > Edit workspace, click on the
three dots (...) to select the corresponding file

I/O window management

e Target name: file containing all the information needed to reconstruct the runtime of the (real) target .TGSX file 1]
e PLC Project: IEC (PLC) application .PPJS / .PPJX file
e HMI Project: HMI pages .PAJX file
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PLC IEC application

already present

3
4

select HMI pages

Manual editing. There is no need to “edit” the workspace when opening Simulation from Application
the TGSX file is created automatically by Application in the folder FREE Studio > Catalog > FreeEvolution >Simulation
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SIMULATION [|| [free

Evolution
FIRST START-UP=

1. Click on the Launch FREE Studio icon on your Desktop
2. Click on the FREE Studio Simulation icon.

oo ="

- ——
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—— s - _— 1 —

1 2

The (empty) workspace appears as shown in figure 2

You can now:

e Create a new project (workspace) WKSX “New ..."

e Open an existing project “Open ...” CTRL+0

e Open recent projects "Recent file ...” by selecting from a list

Simulation projects (workspace) have the extension WKSX

OPENING SIMULATION FROM APPLICATION::

Alternatively, from the Application workspace click on the corresponding Simulation Mode icon!®!
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1. Adialogue window opens from where you can:
e Create a new workspace
e  Open an existing workspace (WKSX)
2. Click OK. The following will appear:
e the Simulation panel®
e TCP/IP connection®: local connection between the Application and Simulation workspaces

From Application click on Download code to "download” the IEC application to the Simulator.

the Simulation tool is available for Smart and Evolution. We suggest opening Simulation directly from Application. See following paragraph
we suggest opening Simulation directly from Application. Available for Smart and Evolution.

toggle function. Clicking on the Simulation icon opens / closes the Simulation workspace

if Simulation does not start you need to change the target. See Troubleshooting section

reduced to an icon on the main bar

AhWN=
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In panel Al¢! there are two icons for viewing the corresponding panels
e Show IO Windows panels that indicate the status of the I/0O
e Show HMI Window graphic and interactive representation of Evolution

See the example for an Evolution target
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10 panels

Clicking on the corresponding icon E brings up various windows/panels corresponding to the inputs/outputs.
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1/0 panels Analog signal properties

The 1/0 panels window is an “index” window that lists all the windows (visible if the tick box M is selected)
From this window you can add a window or delete/rename the listed windows

To add a variable, drag and drop the element you want to monitor from Application to one or more windows
Analogue inputs and outputs!”! can all be simulated:

For inputs, a slider is available for modifying the read value

For outputs, a status / progress bar is available. For digital outputs, green if the output is not active, red if active
The other elements that can be simulated are!®

e Global shared

e Target variables

Note: Also includes BIOS parameters and EEPROM parameters!9l.

the full description is available in the Simulation manual. Press F1 to view the PDF
for digital I/0 see HMI Window

in general each object that has a Modbus address

Evolution only

0 N O
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Each element on the various panels has properties that can be edited using icon

Signal Properties

From this window you can view / modify
e Signal label: label of the variable/resource

e  Variable name: non-modifiable. Indicates the name present in the IEC code

e Read only if the tick box M is selected, the variable is read-only

*  Min value/Max value: the ranges of the resources are set by default. You can manually define / reduce the range that you
want to view by selecting the tick box ¥

HMI Window

Clicking on the corresponding icon brings up the visual representation of the Evolution target (virtual instrument)
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HMI Window

From this window you can simulate the status of digital inputs and outputs

If the output is active it is coloured red

EEPROM parameters can be reset using the Rst E2 key

Finally you can navigate in the menu using the keys of the virtual tool, as if operating on the physical target

OPENING SIMULATION FROM USER INTERFACE:

Exactly the same as Application. Click on the corresponding Simulation Mode icon!'"!

Smart

The example for a Smart target is exactly the same
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10 we suggest opening Simulation directly from Application. Available for Smart and Evolution.
11 toggle function. Clicking on the Simulation mode icon opens / closes the Simulation workspace
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ELIWELL SUPPORT [|| [free

ELIWELL TECHNICAL SUPPORT

Eliwell provides access to fully trained, professional technical personnel to answer its customers” questions precisely and
reliably.

Our technicians are on hand every day, to respond to any technical requirements relating to the installation and operation of all
Eliwell instruments.

If you have any questions or require support, contact Eliwell Technical Support:

Tel. +39 0437 986 250

E-mail: eliwell.freeway@invensys.com

Before contacting Eliwell Technical Support please check the software version of Eliwell FREE Studio.

From the drop-down menu select Help > About
The following screen appears!':

dlill
Studio - Application

IEC 61131-3 development emaanment

e | B
g e i i PRp
et B
Pt ' RV imad
i |

|

Quote software Version, Build and Computer ID

ONLINE HELP

During each program development stage, pressing the F1 key opens a PDF document containing the entire Online Help in
printable format

dliv4ll

M) stubio

Development software for free Smart

i wl
===

PROGRAMMABLE CONTROLLERS

S
&
M

FREE Studio offers developers On-line Help to assist programmers with each stage of program development.

1 Example for Application. Same screenshot for Device. For Evolution users, the screenshot is the same for UserInterface and Connection
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ONLINE HELP - LED=

From the panel Project>Resources>Help access the LED reference for the developer’® section which contains a description
of the characteristics of the icons used in FREE Smart and how to manage them using target variable sysLocalLeds[])
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WEBSITE RESTRICTED AREA

The Eliwell website www.eliwell.it includes a restricted area, access to which is by password only.

Once accredited to access the restricted area with a personal Username and Password, users can view documents, information,
product updates and software which is not openly visible on the site.

Click here to visit the respective web page and obtain all the necessary information for registering

S —
- —— ——— L L - — -
- -
il
- CoISTTT™ i —

The FREE Studio documentation is available to registered users in the section Applications > Programmables > FREE WAY >
FREE Studio.

Software updates are available to registered users in the section Technical Support > Programmables Area > FREE WAY >
FREE Studio.

Applications and libraries are available to registered users in the section Technical Support > Programmables Area > FREE
WAY > FREE Studio > FREE Applications.

2 only available for Smart.
3 see full screen (CTRL+U)
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The tables below show some examples of error messages and the corrective action to be taken.

For messages not shown here, contact Eliwell Technical Support or consultwww.eliwell.it

APPLICATION

Error message

=t 12 e e E

e B o

[T I.

ComServer icon
not visible in the applications
bar

Invalid memory image file.
Please upload memory
image from the target

DEVICE

Error message

invalid connection string

SIMULATION

Error message

no target definition for
simulator (TGSX) found
Unable to run simulator
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Panel

Communication

Communication

Output

Panel

Connection Status

Panel

Effect
target not connected

target not connected

compilation error

Effect

target not connected

Effect

Simulation doesn't start

Resolution

Check the COM port settings
using the drop-down menu
Communication > Settings

EWDMI Properties

disconnect communication
hardware (e.g. DMI, USB/485
converter, etc)
Note:
disconnect the target end
first and then the PC end

connect FREE Smart target
device to PC by means of
DMI

Resolution

Check the
communication settings
by using the menu
Communication > Settings
EWDMI Properties
or by
editing the string from the
menu
Communication > Advanced

Resolution

from panel
Project > Select target
select the correct target
from those available and
confirm with Change



The table shows some of the key combinations (shortecuts) available for enabling/disabling the main functions of Application.
For Device see next table and/or Notes column.
Connection and User Interface have shortcuts for opening, saving and compiling projects
The “toggle” function indicates that the function is enabled if disabled and vice versa by using the same sequence of keys.
For example: CTRL+U enables Full Screen; pressing CTRL+U disables it again!™

The Online Help is activated using the F1 key

Menu Function Function Shortcut Notes
printable HELP in
ALL ONLINE HELP HELP F1 PDF format
ALWAYS AVAILABLE
APPLICATION SHORTCUTS m
Menu Function Function Shortcut Notes
Edit Print Print CTRL+P falell
Edit Cut Cut CTRL+X ok
Edit Copy Copy CTRL+C ok
Edit Paste Paste CTRL+V oo
Edit Save Save CTRL+S ol
View > Toolbars Full screen Full Screen CTRL+U Toggle***
View > Toolbars 138 FBD BAR CTRL+D Toggle
FBD bar
View > Toolbars LD bar LD BAR CTRL+A Toggle
View > Toolbars SFC bar SFC BAR CTRL+Q Toggle
View > Toolbars project bar PROJECT BAR CTRL+J Toggle
View > Toolbars network NETWORK CTRL+M Toggle
View > Toolbars document bar DOCUMENT BAR CTRL+N Toggle
View > Tool Windows workspace WORKSPACE CTRL+W Toggle
View > Tool Windows output OUTPUT CTRL+R Toggle***
View > Tool Windows library LIBRARY CTRL+L Toggle
View > Tool Windows watch window WATCH WINDOW CTRL+T Toggle***
) . L ASYNCH GRAPHIC P
View > Tool Windows asynch graphic window WINDOW CTRL+K Toggle
if more than one
PROJECT COMPILE COMPILE F7 project, compiles
only selected project
COMMUNICATION Download code DOWNLOAD CODE F5
when the variable is
. . ADD SYMBOL TO selected
DEBUG Inserts new items into watch WATCH F8 T
needed)
. . INSERTS NEW ITEMS .
DEBUG Inserts new items into watch INTO WATCH SHIFT + F8 chosen from a list
1 in Device, the display of the panels is defined by the View menu, by checking individual headings or leaving them unchecked
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Menu Function Function Shortcut Notes
ADD SYMBOLTO A
PEEUG DEBUG WINDOW FY
INSERTS NEW ITEMS
DEBUG INTO A DEBUG SHIFT + F10
WINDOW
ADD/REMOVE
PIEEHe BREAK POINT F12
ADD/REMOVE
DEEUE TEXT TRIGGER F9
ADD/REMOVE
DEBUG GRAPHICTRIGGER ~ “HIFT+F9
DEBUG REMOVE ALL TRIGGERS CTRL+F59H'FT "
DEBUG Trigger list CTRL+I
*** also applies to Device
DEVICE SHORTCUTS Dé
Menu Function Function Shortcut Notes
Edit Print Print CTRL+P ikl
Edit Cut Cut CTRL+X FxE
Edit Copy Copy CTRL+C K
Edit Paste Paste CTRL+V ok
View > Toolbars Full screen Full Screen CTRL+U Toggle***
View > Tool Windows output OUTPUT CTRL+R Toggle***
View > Tool Windows watch window WATCH WINDOW CTRL+T Toggle***
View > Tool Windows asynch graphic window EOMNCRE el CTRL+K Toggle***

PARAMETERS
PARAMETERS

PARAMETERS

read selected

write selected

select all

*** also applies to Application

WINDOW
READ SELECTED

WRITE SELECTED

SELECT ALL

CTRL+SHIFT+R
CTRL+SHIFT+R

CTRL+A

the selected
parameters are
highlighted in yellow

Operation to be
performed with care
The next operation
could be writing all
parameters and/or
resetting the default

values
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IIEY evolution

USER INTERFACE SHORTCUTS

Menu Function Function Shortcut Notes
CONFIGURATOR BAR new project NEW PROJECT CTRL+N xk
CONFIGURATOR BAR open project OPEN PROJECT CTRL+O ool

. GENERATE CODE
CONFIGURATOR BAR generate code (compile) (COMPILE) F7
*** also applies to Connection
CONNECTION SHORTCUTS Co
Menu Function Function Shortcut Notes
MAIN BAR new project NEW PROJECT CTRL+N xk
MAIN BAR open project OPEN PROJECT CTRL+O ol
MAIN BAR Save Save CTRL+S
*** also applies to User Interface
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PROJECT 1 - COUNTER

In the pages that follow, we will guide you through the procedure for writing, testing and downloading to FREE Smart a simple

COUNTER program written in ST language, which performs a count and displays a “saw-tooth” on the oscilloscope.

The COUNTER program counts the local variable a from 0 to MAXSCALE1. When a reaches MAXSCALET1 it will be re-initialised
to -100.

As previously described in First Start-up,

e start Application,

e create a new COUNTER project

e create a COUNTER program in ST language

In the central Edit section, write the COUNTER program code in ST language.

COUNTER program

if a>MAXSCALEl then
a:=-100;

else

a:=a+l;

b:=a*10;

end if;

count:=a;

counterl:=b;

Local variables

In the variables section we create the DINT type local variables a and b (use the drop-down menu Variables > Insert, or the
icon Insert record) and associate the Init Value 0 (zero).
The variables a and b are of no use outside the COUNTER program, and are therefore defined as local.

Variables and global constants

In the program, we have also included a constant which we will define as “global”:

e the constant MAXSCALE1 must be created in the panel Project >Global Variables Constants, which we will create here
in the same way as we create a local variable. MAXSCALE1 has a preset value of -100 so it is not necessary to define itas a
variable but as a constant

Global shared variables

Should you want to display the result of the counter on the target, in the program we have also included 1 variable which we
will define as Global shared!™!:

The variable count, which we will create, is obtained from the panel Resources>Modbus Objects > Status variables and not
from the section Edit/Variables, when we enter a new record.

In this case it will be necessary to also define how the name of the variable will appear on the FREE Smart 7-segment display
(e.g. label of up to 4 digits, for example CNT for count) and mapping between Application Type and Device Type.

In the COUNTER program we have included another variable, counter12], which we will define in the same way.

In this case, we do not define how it appears on the display.

The software will propose COUn by default (instead of COUnter), in other words it will use the first 4 letters on the 4-segment
display.

1 note that the folder “Global shared” appears if, and only if, we define the variable in the tab Resources>Modbus Objects > Status variables

2 note that if we had created a variable countexr and not counterl atthe compilation stage, we would have had an error (name conflict
between COUNTER program and variable)
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Fundamental state display

By clicking on Resources>FREE Smart we choose what to show as the fundamental state display!®!
We choose the variable count (which is the value of the local variable “a")
We update the program by entering an always active or always inactive alarm

if alarm then

alarml:=0;

else

alarml:=1;

end 1if;

The alarm variable must be defined as a local variable - of BOOL type (Boolean).
FALSE is proposed by default as the initial value - to change it simply key in TRUE.

The alarm will be always active. We can enter a description such as “Alarm always active”
Alarm1 must be defined in the panel Resources>Alarms. As a label we enter ALM1

Menu creation

At this point we can create
e the customised menu PRG1 for entering any parameters defined by the developer (or use the existing BiOS parameters)
e the customised menu SET1 for entering the 2 variables count and counter1

Task
If we go back to the Project tab and select the task Timed we can add the program COUNTER.

Compilation

We compile the project - drop-down menu Project >Compile (or F7)
Note: the project is compiled without errors and without the need to use a FREE Smart connected to the PC

To summarise...
... see screenshots

g = 1 - prme—
T' EI —-— e —— E.‘,.__._ = —_ — -
- = S = =
= = g g
: g — T .
COUNTER program - Project tab COUNTER program - Resources tab COUNTER program - Resources tab
fundamental state display defining Variables

3 as you can see, the choice includes the default /O + the variables created by the developer
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COUNTER program - Resources tab COUNTER program - Resources tab COUNTER program - Resources tab
menu Set (SET1) Alarms menu defining Variables
Notes

in the Project tab, the global shared variables appear only after they have been declared in the Resources tab. In the example:
e Alarms = allarme1

e  Parameters = PAR1

e Variables & count and counter1

Connecting to FREE Smart and downloading the application

After connecting FREE Smart to the DMI and PC on the USB port and making the appropriate checks on the COM and baud rate

(see relevant chapter) we can connect to the target:

e from the drop-down menu Communication > Connect or icon Connects to the target connect to FREE Smart

e if connection is successful, the message CONNECTED appears in green at the bottom right of the screent!

e from the drop-down menu Communication > Download code (F5) or icon Code download now download the
application to FREE Smart

e one or more dialogue boxes!® will appear, indicating that the application will be downloaded. Downloading could take a
few seconds

ST 1< Shuda Aoskcation 2
Ty Tw srmacty i g wprim, :"_-,
,__?.ul - PLC vl b resed, o Lhe syslemn, conliense 7 — -
- - - { | —
3 > | sl e
e e e
IEC application existing on target reset PLC application download in progress

continue confirmation reset confirmation

The application is not operating on FREE Smart.

4 should this not be the case, see Download on target or Troubleshooting
5 depending on whether the target has already been programmed or not
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Watch and Oscilloscope

On the display of the target device, the count!! value appears which ranges from -100 to +100.
Note that the alarm LED appears because the alarm is active

In the Status menu, we can check for the presence

e  of the folder SET1 with the variables CNT and COUNt

e  of the folder AL with the alarm ALM1 to 1

On Application we can test the value of the variables and display them as text or graphics simply by dragging the variable from
the code in the panel Watch and Oscilloscope
See screenshot below
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¢ Note how the local variables a and b cycle from -100 to 100 (x 10 for variable b), as do the corresponding variables count
and counter1

e "Allarme" is an always true Boolean variable (TRUE shown in red”) and allarme1 is fixed at 1

e The variable count is displayed in the oscilloscope and we can see the “saw-tooth”

Saving the project
We can save the project as counter.ppjs or a name of our choice, generate an .rsm file, password-protect it and exportit as a
library object (.pll).

DEVICE

The project can be opened with Device:

we open the tool of the same name, from which we can read or write one or more BIOS parameters, change them and/or
download the default again.

It is possible to read the current value of the variables defined by the developer but not change them

Device does not require the user to know any programming language; the source code is not visible.

Device requires you to connect to the target device again (click on the respective icon). The central panel shows the protocol
references, address, etc. The default name of the target device is FREESmart_1!8l.

When the target device is connected, you can read the parameters or write the default or changed parameters.

6 count is set as a fundamental display. If you do not set any variable, the message PLC appears
By pressing F5, FREE will appear and you can access the variables and parameters of BIOS

7 if you change "Allarme" from TRUE to FALSE, re-compile and download the new application, the alarm LED will switch off and the variable will
be indicated in green in the Watch panel

8 by simply using the copy/paste function, you can create a twin project FREESmart_2, change the BIOS parameters and download them to the

target device or a second target device
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Reading parameters

Suppose we can't read all the parameters (Read all device parameters)
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As we can see, there are configuration parameters which have default values other than those present on the target device
(highlighted in blue)

Displaying variables

As with Application, with Device it is also possible to display the variables simply by dragging them to the Watch and
Oscilloscope panels.

Writing parameters

Suppose we want to download all the CL parameters (local BIOS) and no others.

Select all the parameters - drop-down menu Parameters>Select all (CTRL+A) or using the respective icon B. The parameters
are all highlighted in yellow. Write drop-down menu Parameters>Write selected (CTRL+SHIFT+W) (or using the icon W)

All the CL parameters will be downloaded to the target device.

CF folder Watch/Oscilloscope CL parameters (all) download in
parameters CF31 and Ui26 with variables count and counter1 progress
different default values from the
application

We can save the project as Counter.CFN or a name of our choice.
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PROJECT 2 - COUNTER2 FUNCTION BLOCK

Starting from the COUNTER program described in the previous example, we create a function block and we modify the IEC
application by adding code for the switching of a LED / relay.

Saving the project
We save the COUNTER project by renaming it COUNTER2:

from the drop-down menu File>Save project as proposes the COUNTER work folder.
Go up one level, create a new COUNTER2 folder and save the project as COUNTER2.

Creating a function block

Create a new function block COUNTERST in ST language.
Copy/paste the COUNTER program into the Edit panel of the function block with several variants

COUNTERST program (function block)
if a>MAX then

a:=-100;

elsif enable then
a:=+1;

end 1if;

out:=ay

Local input and output variables

In section B!" variables we create the following variables:

e aaslocal variable

e MAX and enable as input variables to the function block

e out as output variable from the function block

The function block will therefore have 2 input variables, one output variable and one local variable which will save the
status of the counter in each instance of the function block
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1 see Application Panel Definitions
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We now write the COUNTER2 program in which the functional block will be called
The function block will have 2 instances CounterSt1l, CounterSt2 defined as local variables of CounterSt type

As we write the code, note how Application guides the developer writing the code by proposing the variables to pass to the

function block!
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The Boolean variable in this case will serve to switch
® asuitably configured relay
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e an LEDP! of the target on the basis of a defined condition

We now write the new code COUNTER2

COUNTER2 program

CounterStl (enable:=not Enable Counterl,

counterl:=CounterStl.out;

CounterSt2 (enable:=Enable Counter2, MAX:

counter2:=CounterSt2.out;
alarm:=(counterl>counter?2) ;
if alarm then

alarml:=1;
Alarm relay := TRUE;

else

alarml:=0;
Alarm relay

FALSE;
end if;

if (counterl<=counter2) then

MAX:=MAXSCALEL) ;

=MAXSCALELl/2) ;

sysLocalleds[6] :=1;
else
sysLocalleds[6] :=0;
end if;
2 in the example 2 input variables (identified by an icon with the arrows on the left, and the output with the arrows on the right)

we use the variable target sysLocalLeds . See relevant section
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In the Resources tab, it is necessary to create and/or rename, from the previous project,
the EEPROM parameters, status variables, etc.
It is also necessary, if desired, to add the resources to the Prg menu and set menu

In the I/0 mapping menu, lastly, it is possible to associate resources to the inputs/outputs
We associate Enable Counterl to adigital inputand Alarm relay to an output
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Exporting to target device

From the drop-down menu Developer>Export application to catalog remember to export the project to catalogue so as to
enable Device to re-use it for downloading to the target.

Before exporting to catalogue, use the drop-down menu Project>Options to assign to the project a release (e.g. the same
name counter2), a version (e.g. 1.0) and compile the project again.

This will enable Device to recognise the IEC application on the target when it is downloaded.
Compile the project and download it to target by means of Application or Device.

The counter will display a count from -100 to 100 in the same way as the [IEC COUNTER application previously described.
In this case, the Alarm LED will switch to the compressor LED!# once the defined threshold has been reached.

4 SysLocalLeds[6], The alarm LED is SysLocalLeds[16]
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